Loss of scrolling, unwanted hyperlink opening in new window, unexpected text selection

Hi, i'm using Zorin os for a year, v16 and now v17.
Few weeks ago, I have noticed, strange behaviours : Loss of scrolling in files and internet browser, unwanted hyperlink opening in new window and not in a tab, unexpected text selection instead of changing the cursor's location.
They all appear at the same time, and at the moment the only solution is to close my session and reopen it.
When these behaviours occurs, it happens 3 or 4 times in a row. That is, they reappear a few seconds later after a session has been reopened.

I made upgrade to v17 4 days ago and I was hoping this would solve the problem. But no.

Is somebody has an idea and can help me ?

These sound like cursor actions being acted on. Are you on a notebook computer with a touchpad?
Do you use a USB Mouse?
Do these actions occur only when you are typing?

This is my exact configuration, notebook and USB mouse.
But I'm not sure when it happens, if it's during I'm typing. I type a lot with my computer, so it's very likely.
And I don't know if it's another symptom, but sometimes the "settings" buttons lead to the "main menu" window.

You can try disabling the touchpad to see if that resolves the issue:

But the problem is that I regularly use the touchpad too. Disabling it isn't really an option.

When you type (this may take some concentration), try to notice if the pads of your hands (where your thumbs meet your palms) are making contact with or brushing against the touchpad. This can narrow down the cause.

If they are, then only a physical solution can resolve the issue with the desire to use the touchpad. I prefer the notebook configuration that has the touchpad off to the right (Next to Numpad) so a user must move their hand the same way as with a mouse and clear the keyboard. Sadly, very few manufacturers have the brains to do this.
The system cannot be programmed to know an accidental touch from an intentional one.

1 Like

In fact, it's happening very regularly. But I've activated the option to disable touchpad while typing. But yes, the cursor often jumps from one place to another as I type, which is annoying.

Capture d’écran du 2024-02-12 08-56-35

From this post, we can speculate that either the software is failing to disable touchpad while typing, or the touchpad itself has a driver fault.

Can you please list the specs for your touchpad or Manufacturer, make and model of the notebook?

My laptop is an Asus Zenbook UX303L and here are informations about the touchpad from lshw:

  *-input:2
       produit: FocalTechPS/2 FocalTech Touchpad
       identifiant matériel: 3
       nom logique: input11
       nom logique: /dev/input/event4
       nom logique: /dev/input/mouse0
       fonctionnalités: i8042

Have you yet tested:

rmmod psmouse && modprobe psmouse

This is one of those issues that kind of spins you about. The issue began a few weeks ago, implying a system update brought it along. However, you since upgraded from Zorin OS 16 to Zorin OS 16, which would have brought new kernel modules.

Having the touchpad disabled while typing is set.

...
A while back, I noticed my mouse (USB) began showing an erratic cursor. I would move the mouse, but the cursor stayed put or warped jumped to new locations.
Admittedly, I did not check any software first.
I turned the mouse over. Sure enough, little cat hairs had wadded up in a ball inside the laser port. I pulled them out and the mouse was fixed.

In the case of your touchpad, there may be a hardware issue of some kind that is causing this. An easy check would be to use a LiveUSB of Windows OS and check if everything behaves normally on that Demo version.
You might try with a LiveUSB of Zorin OS just to know.

Also, check your USB mouse in case it is interfering with the touchpad. You might test unplugging the mouse, rebooting and using just the touchpad to see if the trouble continues.

Ok, this command seems to correct symptoms.

Yes, this bug appears when I'm using USB mouse or touchpad. I have tried to unplugged USB mouse dongle and only used touchpad. Issues appears too.

Long term or only during the session in use?

As I don't remember off the top of my head, and I'm not fluent in your language, the slider for disabling TouchPad while typing is either to increase/decrease the delay (which I would decrease if that is the case, or it's a TouchPad sensitivity setting, which I would also modify in order to see if they have any effect on whether the TouchPad becomes active while you are typing.

Also changing the sensitivity in the mouse settings, under the TouchPad sensitivity.

This may very well assist with preventing accidental activation of the TouchPad.

It works for a session in use, and sometimes it appears again during this same session.

Strangely enough, I'm now having additional problems. The mouse and keyboard very regularly have delays between clicking/typing and display. An example, the tab change, which reacts very slowly whether you use ctrl + tab or the mouse. I don't know if it's related, but I'm adding it.

That is a known touchpad bug and is OS agnostic. I used to be a Vision Support Technician supporting students with low-vision. Support staff would come to me with this problem with Dell notebooks. I had to ask IT department to download the Touchpad GUI from Dell to lock the touchpad.

There is no Linux version of touchpad GUI Asus Smart Gesture.
So I'm trying to install the Windows version with Wine, but it's been running for 5 hours.
I'm not sure if it is a good option.

It's strange, everything was working fine 2 months ago.

It may be a kernel update that caused the issue. At the grub screen, choose advanced and select an older kernel (the first one will be the newest), not the recovery version. Boot and test.

If you have no issues, the search of the forum will give you a how to set an older kernel to boot, in tutorials category. I'm sorry, but I don't have the link easily obtainable at the moment.

You will have to try newer kernels, as they are released, and see if the issue persists.

1 Like

I would not hedge any bets on this... Wine is good for supplying a compatibility layer to run third party Windows software, but it is not intended to use for System Software.

1 Like

Anything to do with settings is going to be looking for specific registry values to change in Windows. As mentioned above, by Aravisian, Wine is a compatibility layer and does not contain a complete windows registry. The settings registry entry that you are attempting to modify very well may not exist.

As Asus doesn't offer Linux variants of software, you may find similar applications written by Linux users, but otherwise, are not able to use it.

I would love to use the Asus software for my laptop. It's ability to optimize games by a slider for performance or quality is amazing. But, that's why I dual boot. I get all of the hardware updates (I'm talking about device specific firmware updates for the device [bios, nvme drives...]) for my machine and work in Linux.