Lost internet after installing system updates

Hi, first post here.

I installed OS 16.1 about a month ago and have been enjoying it. Yesterday I happened to check for updates and noticed a large package. After installing it, I now I have no internet access.

My computer is a 2020 Lenovo Legion 5.

The network manager shows that the computer is connected, but when I open a browser, no pages will load. Likewise when I try to check for updates or run a terminal command, nothing happens because I'm offline.

I have tried 4 different types of connections:

Wi-fi from my router
Ethernet from my router
Wi-fi from my phone hotspot
USB tethering from my phone

All of these methods used to work fine, and now none of them do. I'm typing this post from my Windows 10 machine, which is having no issues.

I've found some similar posts about Ubuntu and various solutions, but they are all Catch-22 situations requiring internet access to restore internet access. The only successful resolution I saw was a complete reinstallation of the OS. What a hassle. Is there anything else I can try?

Thanks.

Had you used a proprietary driver to connect to the internet ?

Hmm, not that I know of. I bought the laptop with Windows 10 installed. The internet always worked and continued to do so after I switched to Zorin. Only after the Zorin system update did I have trouble.

You probably would have remembered installing them from additional drivers if you had. Try selecting the previous kernel from the grub menu. and if the internet works it probably means your internet adapter is not supported by the latest kernel. If it works check additional divers to see if any are available.

1 Like

Thank you. How do I do this? I'm not familiar with the grub menu or how to find a kernel in it. I can barely run a terminal command.

Tapping esc or tab beginning when you see your motherboard splash screen should pull up the Grub Menu.
From there, you should see Advanced Options for Zorin. User the arrow keys to navigate and select the Advanced Options, then arrow key down to the older (lower number) kernel - press enter to select.

Thanks. ESC brings up a menu, but it flashes so fast past the first screen that I can't see what the menu is. Then it goes to a screen that just says "grub" one line after another. No Advanced Options that I can see. I also tried Shift to enter the menu -- no luck.

The Left Shift Key for pulling up grub is for MBR (Legacy) Installs.
For EFI systems, the Esc key or the Tab key should be used.

If grub is flashing by too fast, then then grub timeout may be set to low. By default it is set to Ten Seconds - plenty of time to read and make a choice on grub.
Some guides to speed up Boot Time can tell people to lower that timeout or even eliminate it by setting it to 0 and this... is bad. Because as you just experienced, that can really shoot you in the foot when you need a moment to see and access grub.

Can you please Boot Up and log in...
Then open a terminal and run

sudo nano /etc/default/grub

Look for this line:

GRUB_TIMEOUT=

Ensure that is set to 10 seconds;

GRUB_TIMEOUT=10

If you change that value, tap ctrl+x when finished, then the y key to say yes to save, then the enter key to save as the currently configured file and exit.
The terminal will revert to normal.
Reboot, then try accessing grub menu.

Thanks, Aravisian. I did this and was able to set the timeout to 10. Indeed it was set to zero.

Unfortunately, even with the timeout now set to 10, the grub menu still flashes by as if still set to zero. I went back to make sure my change stuck, which it did, yet the timeout is still instant.

Is there anything else I can try short of a total reinstallation? And if I do that, will it restore whichever driver I had originally for connecting to the internet? Or is that gone regardless now after the attempted system update?

Thanks again for your help.

Ah um... my fault.

After changing the grub file... you need to run sudo update-grub in terminal in order to get the system to recognize the changes.
I should have... mentioned this in the above post...

OK, I ran "sudo update-grub" and got a "done" at the end. Unfortunately upon rebooting and entering the grub menu, I get the same problem -- flashes by so fast that I almost can't notice it.

Odd...
Can you sudo nano /etc/default/grub

again, and find the line: GRUB_TIMEOUT_STYLE=hidden
Comment it out so it looks exactly like: #GRUB_TIMEOUT_STYLE=hidden

Set the timeout to 15 or 20
Then ctrl+x, y key, enter key...
Run

sudo update-grub

..and test...

OK, thank you for your persistence with me on this. I tried as you said, added # to the timeout style line, set timeout to 20, saved, then updated grub again.

Still no luck. The menu still flashes too fast to see.

I notice that the top line of the grub file "grub default" is also set to zero like the timeout line. Maybe this too needs to be lengthened? Or should that top line value indeed be set to zero?

As an experiment, I created an ISO of Mint 20.3 and booted it from the USB. My internet works fine now. So evidently something got changed or removed from my installed Zorin. This gives me hope that it can be restored. If only I can find it.

Yes, I agree that @Winged1 made the strongest suggestion.
Mint 20 is using an earlier kernel.

I am not sure why your Grub file is not working properly - much less why it is so changed from default. Have you used "Grub Customizer" application at any point?

When the grub does show, use the down arrow key (press it once) and it will negate the timer as well as keep you there until you make a choice.

I have not used Grub Customizer. But I notice today that I'm now getting what appears to be the grub menu on normal startup -- without pressing ESC. It now comes up for 20 seconds (where I set it) and gives me Advanced Options for Zorin as the second choice.

When I select that, I get a list of 4 options -- 2 labeled "generic" and 2 called "recovery mode." Are any of these what I'm looking for? I tried selecting the first recovery option and got a long string of code running down a black screen.

Then a tiny red menu appeared with options like "clean" and "repair broken packages." I ran the latter and rebooted. Still no internet.

Starting to wonder if I should just install the Mint 20 from yesterday and go forward with that instead.

I seem to be back up and running now. After two failed attempts to install Mint 20, I went back to Zorin 16 and did a total reinstallation.

This time I used the standard version rather than the one with Nvidia drivers, even though my laptop is fairly new (2020) and Zorin says I might benefit from them. Not sure what the consequences might be later, but for now the system is fully updated and connecting to the internet.

Next I'll try to figure out Timeshift or some other backup method in case a similar problem comes up. Quite the hassle to reset preferences and re-download software.

Side note: This new installation is much faster at startup than the original one, which took a while and gave me a screen of scrolling code before finally going to the login. Hmm. Maybe I should have installed the standard version in the first place.

I wonder if you were using the 470 (Proprietary Tested) driver.
The 470 is fine and the 510 (Proprietary Tested) is fine. But the 470 (Proprietary Tested) is known to have bugginess.