Lutris is stuck on lutris is starting page

hello guys, how r u?
Btw i just installed lutris (i think all knows what is it) i used the official guide to install it (i added the ppa, runned sudo apt update, and thene sudo apt install lutris, but when i launched the app is stuck on "lutris is starting" i tried to search online and found that i have to run a command so i run it and then tried again to open lutris it doesn't change anything
P.S when i close the app he gaves me pop-up where he says "lutris was unable to find vulkan support for the i386 architecture this will prevent many games and program from working ecc" so i run the command "uname -m" to see if my architecture was 32 or 64 bits and it gaves me it is 64 so why does lutris tell me to install something that is needed for 32 architecture??

one more thing when i close the pop-up lutris starts but the page of lutris is starting doesn't dissapear and when i search for games it gaves me that he doesn't found anything

I found this issue posted here:

In particular, Jeff Pearson's response appears to explain this:

To install WINE development branch in Ubuntu base, you need to install libfaudio0 32 and 64 bit versions…I was getting same depends error until I figured that out…there are instructions on winehq Ubuntu site…at top of page

1 Like

sorry i got a lot to do so i can't read all the things could u please tell me the command to execute
thx a lor dude.

Lutris is already listed under Synaptic, so I don't know why you'd need to add the PPA. I recommend checking what version you have. Synaptic shows as - any other version may not work properly.

Unfortunately, you may have to do some reading or post on the Wine forum, as linked by 337harvey. You may or may not need DXVK. If you do need it, it can be easily added using PlayOnLinux. For Lutris, I don't know. This also depends on if you indeed need DXVK.

1 Like

ok thx when i got time i will read it hope that's nothing difficult

ok so i have also searched online and they said that i have to run this command which has the word DXVK so i think that i already got this thing installed. the command i runned is wget -P $HOME/.local/share/lutris/runtime/dxvk

ok so if it can help i also runned lutris with the terminal and the terminal gaves me this info's
username~$ lutris
Gtk-Message: 21:44:47.530: GtkDialog mapped without a transient parent. This is discouraged.
2021-03-23 21:44:47,532: Initializing lutris
2021-03-23 21:44:51,488: Runtime steam is not available locally
2021-03-23 21:44:51,490: Runtime lib64 is not available locally
2021-03-23 21:44:51,492: Runtime lib32 is not available locally
2021-03-23 21:45:27,325: Lutris
2021-03-23 21:45:27,326: Running X.Org Mesa driver 20.0.8 on AMD STONEY (DRM 3.35.0, 5.4.0-67-generic, LLVM 10.0.0) (0x98e4)
2021-03-23 21:45:27,327: GPU:there's a code idk if i can show this
(amdgpu drivers)
2021-03-23 21:45:27,328: i386 missing (needed by vulkan)
Gtk-Message: 21:45:27.646: GtkDialog mapped without a transient parent. This is discouraged.
2021-03-23 21:45:47,453: Shutting down Lutris

I recommend asking here - I use PlayOnLinux, and, as I linked in my last post, the installation is straightforward. I know nothing about Lutris.

ok thx, btw i know that there's also playonlinux but i'm a complete noob with linux (i only know some basic commands) so i prefer lutris bcs is much easier

Add 32 bit architecture.

sudo dpkg --add-architecture i386

sudo apt update

sudo apt full-upgrade

1 Like

my pc is 64 bit not 32

Yes, but you still need the architecture for 32 bit support.

Read the " Enabling Multi Arch on Ubuntu 18.04 LTS" section on How to Run 32-bit Windows Programs on 64-bit Ubuntu 18.04 LTS – Linux Hint

One of your posted messages was: i386 missing (needed by vulkan)
That is why Aravisian made his recommendation.

The forum i related in my last post is the forum specifically dealing with this topic. It has help links and even two videos to follow with step by step instruction all covering lutris install on Ubuntu and other distros. When you have time read from the beginning of that forum and attempt the steps explained. This isn't a quick fix and the commands may have to be entered in order so dependencies are installed. I recommend you try that.

I'm sorry you're having difficulty with this, and i an trying to be supportive. I have never used nor heard of lutris prior to your post, something i should look at since origin on playonlinux isn't working out so hot. I am new to this as well. That said you really need to invest a little time in learning and preparing your computer if you want it to work. This is the trade off... having everything dictated how you do it (windows), to having the freedom to learn and do it how you want.

If you can't make time to prepare your machine, how do you expect to have time to play on it. Do you make time to get gas, or expect someone else to fill your car for you?

Please stop looking for a quick fix and do a little reading, comprehension and perform for yourself. Otherwise you'll be in the same boat every time something changes, new software comes out, or the kernel is updated. We help out of kindness, but it shouldn't be expected to hand you the fix. We don't have your system and can't predict the issues you're running into. Do a little for yourself.

I'm sorry if that came out somewhat d*ckish, but understand that even Microsoft couldn't do everything for you.

1 Like

Perfectly stated.

you're right i tried to read but i didn't understand much so now i try to add the 32 bit architecture thing and if doesn't work i will go with the videos

Oh ok i didn't know that thx i will try

Supashang's post may help you the most with the dotnet and vulkan drivers. Make sure to clear the compdata folder he lists on his post.