Lutris lag with AMD GPU (R5 m230/R3 Graphics)

Hello everyone, hope you're doing well.
I'm stressed since I installed Lutris in Zorin OS. (Even though I love it).

So, basically I installed Lutris from the Software Store, installed Wine 7.0.0 for Ubuntu 20.04, tried to install a game, it worked because the Zorin Windows Support was installed before I "updated" to the Wine new version.
But when I launched Lutris, I added the Game, when I launch it, it is really laggy and stuttering. Same happens with Epic Games installed via Lutris.

My specs are:
CPU = AMD A4-6210 APU with Radeon R3 Graphics
Motherboard = Larne
RAM = 4GB + 8GB DDR3 1600MHz
GPU(s) = Radeon R5 M230 (CPU-X says it is Jet PRO (wich I think it's the driver)) and Radeon R3 Graphics (Mullins)

Btw, BIOS version is 1.60 made by Insyde Corp.

I think the issue could well be because AMD don't provide Software Tweaks for GNU/Linux users as this article will be for Windows users of AMD graphics?:

Yeah, that solution doesn't apply here in Zorin.
Since I don't even have the "Original/Latest" AMD drivers, just the ones that come with the Zorin OS.
And with these pre-installed drivers, I don't have the AMD Radeon Settings.

Update: Installed the last Lutris release from their repository (having a bug on wich I can't search for games on the Lutris "section").
Uninstalled wine-stable and installed wine-staging, plus the latest drivers from ppa:kisak/kisak-mesa. Uninstalled Epic Games Launcher and installed Rockstar Launcher to get GTA San Andreas + GTA V. GTA SA runs quite playable with DXVK disabled, but GTA V doesn't.

I really with somebody could help me out here :confused:

Have you tried the Oibaf drivers?

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

Sorry for my ignorance, but do I need to uninstall the kisak drivers first?
And remove the repository?

Not necessarily... but you may be wise to do so.
Realistically, either repo may give you the latest available version; in the same manner as an upgrade released from ZorinGroup would. It would replace the older version.

Well sorry for taking ~10m
I did it. EDIT: uninstalled the kisak and ppa repository
Launched Lutris, with the latest runner available.
Rockstar Games Launcher wouldn't work with the wine-ge so I used the lutris one. It is more fluid now, atleast the launcher. When I start the game it just gets stuck at "Loading".

The last Warning in my log is this:

(wine:39680): GStreamer-WARNING **: 02:01:10.704: Failed to load plugin '/home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/': /home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/ classe ELF errada: ELFCLASS32

Don't know if there is something really wrong, I'll try launching the game again.

Why is Wine trying to load 64 bit libraries? I thought Wine only works with 32bit...

Some have better results using Bottles instead of Wine...

1 Like

I'll just show you the last log of GTA V (Rockstar Games Launcher) after disabling DXVK:
So you can see if there is anything even stranger.

Started initial process 76644 from gamemoderun /home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/bin/wine /home/arios/Games/grand-theft-auto-v/drive_c/Program Files/Rockstar Games/Launcher/Launcher.exe
Start monitoring process.
ERROR: object '/usr/$LIB/' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
ERROR: object '/usr/$LIB/' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
esync: up and running.
Initial process has exited (return code: 0)

(wine:78862): GStreamer-WARNING **: 02:14:59.927: Failed to load plugin '/home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib64/gstreamer-1.0/': impossível abrir ficheiro-objecto partilhado: Ficheiro ou pasta inexistente

(wine:78862): GStreamer-WARNING **: 02:14:59.932: Failed to load plugin '/home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/': /home/arios/.local/share/lutris/runners/wine/lutris-fshack-7.2-x86_64/lib/gstreamer-1.0/ classe ELF errada: ELFCLASS32
wine: Read access denied for device L"\??\E:\", FS volume label and serial are not available.
wine: Read access denied for device L"\??\Z:\", FS volume label and serial are not available.

I am not sure on the runners... I am not a gamer and I do not even have Lutris installed.
I only stepped in since you were waiting for a while and Some Ideas may help you find a sense of direction better than no ideas at all.

1 Like

Well thank you sir.
You're really cool, fr fr.

I'm going to try and install Bottles.

Well, Bottles is even worse...
Going to try and solve it by myself, ask in other forums, etc...
Meanwhile if someone is able to help, I would be happy.
Thank you guys.

What about Steam games and/or Proton?

Haven't tried those.
Anyways, had to disable DXVK to run Epic Games Launcher and disable discrete graphics card so it runs (without DXVK) and smooth (disabled discrete graphics card).
Trying to run Darksiders II Deathinitive Edition, yet there is some lag and input lag.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.