Macbook 2015 internal speaker issue

I recently l loaded linux on my macbook 2015. It runs pretty smoothly on this machine, but there is one major issue. The internal speaker doesnt work. I double-checked Alsamixer already and nothing is muted. Further, I downloaded pulseaudiovolume control and checked the default device. The system recognizes when sound should be playing on pulseaudio, no sound is coming out though. re-installing the audio drivers also did not fix this for me. Any help is much appreciated

What version of Linux? Zorin OS Core, Lite, Education, Pro? Was it some other distribution?

1 Like

Im running Zorin Core 16

Is pavucontrol installed?

sudo apt install pavucontrol



Check the dropdown for your output speakers from Output Tab and the dropdown arrow to ensure it is set to a working system.

Sidenote: Sound issues are my worst subject in Linux. :wink:

Hello again :slight_smile: I followed these steps, but still nothing :frowning:

In alsamixer try setting "Loopback mode" to Enabled.
Also try "Auto-Mute" Disabled.

Other than that, in alsamixer hit F5 to show All sound channels.
Then post a scheenshot, making sure all the channels are visible i.e. no arrows on right of screen. We may see something to try from that.

Thank you, how do I go about accessing the "auto-mute" and "Loopback mode" settings? My alsamixer displays the below:

OK so that's HDMI.
If you press F6 do you see any other soundcard listed?
If yes, select that one and then do F5 and post another screenshot.

per your instructions, This is what I have:

auto-mute was already disabled when I landed here. no changes so far

Thats the screenshot I was expecting, but no Speakers channel shown, which is dissapointing :frowning:

I have just done a general websearch using "Macbook Cirrus Logic CS4208 No speakers Ubuntu 20.04". Maybe you want to do that or have done so already.

I found this.

The second answer suggests compiling a driver (says works for Ubuntu 20.04 but not 22.04). Is that something worth investigatng. @Aravisian may wish to comment on that.

Another hit from websearch was this:

Another (old) bug report...

that points to a driver... GitHub - leifliddy/macbook12-audio-driver: WIP audio driver for the cs4208 codec found in the 12" MacBook (MacBook9,1, MacBook10,1).

This one states

Note: the Macbook8,1 (2015) is not supported.

It is worth trying.

You can also try:

sudo nano /etc/modprobe.d/alsa-base.conf

Paste the following into that file

"options snd-hda-intel model=generic" 

Tap ctrl+o to overwrite, then enter to save as current configuration. Tap ctrl+x` to exit the editor.
You Must Reboot before testing sound.

Thanks, Aravisian. your edit to the alsa base config didn't work for me :frowning: the absolute kicker is that the speaker plays that Macbook starting chime every time I reload the machine. It's like it's mocking me. I'm going to attempt compiling the driver suggested in answer two and let you guys know the result

1 Like

The equalizer is showing activity, but still no sound... so strange

No change after building that driver.

That may be a different speaker.:wink:

Many computers - especially older ones - had a dedicated speaker attached to the motherboard exclusively for Critical System Sounds. It could not be used as a Desktop Speaker (At least... not without some hacking).

Your research led me around various places that led me to:

Another user grabbed that with git, then in the extracted directory ran the install script


After which they had sound on a 2015 Macbook Pro with the 5.17 kernel.

I grabbed that git that you suggested and installed the driver, still no luck

On AlsaMixer try changing audio card by pressing F6 and change to another entry. If doesn't fix, Disks > click Unit Options (on the left of Minimize) for your hard drive > Unit Settings… > try AAM.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.