Macbook Air 2019 No sound, no wifi, no keyboard and mouse after installing Zorin Education 17.1

I am using a Macbook Air 2019 and I just installed Zorin Education 17.1. However, I cannot use Mac's keyboard and mouse and also it shows no wifi adapter found and no sound either. I have tried many methods mentioned in the forum but none seems to work for me. Please help me if possible! Thank you!

Here is what I got from the terminal.

uname -a

Linux MeowChan 6.5.0-28-generic #29~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Thu Apr 4 14:39:20 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

sudo lshw -C multimedia
*-multimedia UNCLAIMED
description: Multimedia audio controller
product: Apple Audio Device
vendor: Apple Inc.
physical id: 0.3
bus info: pci@0000:01:00.3
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: latency=0
resources: memory:b0c00000-b0ffffff memory:b1180000-b11fffff memory:b1230000-b123ffff
*-multimedia
description: Audio device
product: Sunrise Point-LP HD Audio
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
logical name: card0
logical name: /dev/snd/controlC0
logical name: /dev/snd/hwC0D2
logical name: /dev/snd/pcmC0D3p
logical name: /dev/snd/pcmC0D7p
logical name: /dev/snd/pcmC0D8p
version: 21
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_hda_intel latency=64
resources: iomemory:400-3ff irq:54 memory:82520000-82523fff memory:4000000000-400000ffff

sudo lshw -C video
*-display
description: VGA compatible controller
product: UHD Graphics 617
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 02
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 resolution=2880,1800
resources: irq:52 memory:81000000-81ffffff memory:a0000000-afffffff ioport:3000(size=64) memory:c0000-dffff

sudo lshw -C network
*-network UNCLAIMED
description: Network controller
product: BCM4355 802.11ac Wireless LAN SoC
vendor: Broadcom Inc. and subsidiaries
physical id: 0
bus info: pci@0000:02:00.0
version: 0c
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress cap_list
configuration: latency=0
resources: memory:82400000-82407fff memory:82000000-823fffff
*-network
description: Ethernet interface
physical id: 7
bus info: usb@1:1.1.4
logical name: enx6c1ff7033486
serial: 6c:1f:f7:03:34:86
capabilities: ethernet physical
configuration: autonegotiation=off broadcast=yes driver=cdc_ncm driverversion=6.5.0-28-generic duplex=half firmware=CDC NCM (NO ZLP) ip=192.168.101.3 link=yes multicast=yes port=twisted pair

I trust you checked the hash key of Zorin 17.iso after downloading and before writing to USB using Balena Etcher. If so, see if this guide helps you:

I have figured it out since I totally forgot that my Mac is using T2 so I followed a guide with T2 Linux and now my problem is solved! Thank you for your kind reply!

1 Like

Glad you got sorted friend.