Macbook Pro 15" 2012 Video Issue

I have searched the forums (as well as the internet), to see if I could figure this issue out... to no avail. Maybe someone here has some input.

I just successfully installed Zorin OS 16 Pro on an old Macbook Pro 15" 2012. When it boots though, the screen goes completely black, then it goes to a blackish static screen that slowly goes completely white!? So strange to watch this! Haha! Anyway... if I boot off of the Live USB, the only option that works is to boot with "Safe Graphics". Everything works perfectly in the Live environment. It only goes to cr*p when I try to boot from the internal SSD.

I did try doing what this guy suggested... Install With Safe Graphics - #2 by Aravisian ...but that didn't work. It pretty much does the same thing.

This Macbook Pro does have 2 internal video cards... an Intel HD Graphics 4000
& an NVIDIA GeForce GT 650M. I did read that some people had issues with having 2 graphics cards and Zorin OS.

So I was wondering if anyone else had some help regarding this.

Thank you!!

This:

Is actually the same thing as this:

So, that makes this very confusing.

Right?? I'm confused as to why it's not working. I booted off of the Live USB, clicked on the "Safe Graphics" option and it boots up just fine. I installed GNU Emacs (that's what I'm used to) and went to /etc/default/grub and edited the line exactly as you said and then saved it. Then I shutdown the system and booted it... I get the same nasty static black screen that slowly turns white. Not sure what's up.

Did you run sudo update-grub to get the changes made to the grubfile loaded into the system?

No, I didn't. I'm making all these changes through the Live USB... if I ran that command, would it make the changes to the correct grubfile that's loaded into the system?

If you have installed Zorin OS to the computers drive, that is where you need to make the changes to grub.

Boot off your Computer Drive (Not Live USB).
Tap the esc key at the grub menu to find Advanced Options for Zorin and arrow key to that and select it.
Then arrow key to Recovery Mode
Enter the Grub Recovery Menu and arrow key down to Drop to Prompt
Hit the enter key, then run your sudo nano /etc/default/grub and add nomodeset within the quotes with quiet splash:
"quiet splash nomodeset"
Exit and save...
Then run

sudo update-grub

Once done, try shutting down, then booting up normally.

1 Like

I just tried booting off the internal SSD (without the Live USB drive plugged in) to get to the Advanced Options by pressing the Esc key and the screen just stays black with a solid cursor (meaning an underscore) and nothing changes. I guess it's not even getting to the Grub Menu?

In that case, try punching in ctrl+alt+F3 to enter into TTY.
Enter in the commands there. While you are in there... should run sudo dpkg-reconfigure gdm3 just in case...

If all fails, I remember one Macbok user temporary used an external keyboard to get into grub screen to fix the issue.

1 Like

I actually did just try an external keyboard and nothing. I'm wondering if something else is going on with this. I'll do more troubleshooting into this (like installing another OS on this Mac or just MacOS itself) and see what happens. If that all works, I'll come back to Zorin OS.

Thanks for all your input, Aravisian and FrenchPress too!

1 Like

OK, I hope to see you again.
Good luck :four_leaf_clover: