Macbook waking up immediately from standby with Zorin 17

Hi,

I installed Zorin 17 Pro on my Macbook. It works well accept that it wakes up immediately after entering sleep mode, whether I put it into sleep mode manually or if it goes there automatically.

My Macbook :

  • Macbook Air 6.2
  • Intel® Core™ i5-4250U CPU @ 1.30GHz × 4
  • Mesa Intel® HD Graphics 5000 (HSW GT3)

The journalctl | grep systemd-sleep command shows me this :

févr. 01 21:20:32 MatBook systemd-sleep[34022]: Entering sleep state 'suspend'...
févr. 01 21:20:35 MatBook systemd-sleep[34022]: System returned from sleep state.
févr. 01 21:20:35 MatBook systemd-sleep[34133]: /dev/sda:
févr. 01 21:20:35 MatBook systemd-sleep[34133]:  setting Advanced Power Management level to 0x80 (128)
févr. 01 21:20:35 MatBook systemd-sleep[34133]:  APM_level        = 128
févr. 01 21:20:36 MatBook systemd-sleep[34175]: /dev/sda:
févr. 01 21:20:36 MatBook systemd-sleep[34175]:  setting standby to 36 (3 minutes)
févr. 01 21:35:38 MatBook systemd-sleep[35669]: Entering sleep state 'suspend'...
févr. 01 21:35:41 MatBook systemd-sleep[35669]: System returned from sleep state.
févr. 01 21:35:41 MatBook systemd-sleep[35782]: /dev/sda:
févr. 01 21:35:41 MatBook systemd-sleep[35782]:  setting Advanced Power Management level to 0x80 (128)
févr. 01 21:35:41 MatBook systemd-sleep[35782]:  APM_level        = 128

Any idea why? How can I identify the source of the problem?

Thans a lot.

First, make sure you've got WoL (Wake On Lan) disabled in the BIOS / UEFI settings. If that doesn't fix it, then continue...

Issue:
cat /proc/bus/input/devices
... and copy the output into a text file.

Then issue:
cat /proc/acpi/wakeup
... and compare the output to what you've got in the text file... look for the PCI address of each enabled device.

I'm betting it's a Bluetooth or USB mouse that refuses to be quiet when the system is sleeping.

This can also happen with certain USB keyboards (ones that are actually the old-style PS2 keyboards, just with an onboard USB-PS2 adapter to convert them to USB).


If you don't actually need your computer to sleep, you just want to turn the screen off, you can disable sleep, then do:

First, enumerate your displays:
xrandr -q

Mine looks like this (display names in bold):

Screen 0: minimum 320 x 200, current 1600 x 900, maximum 16384 x 16384
eDP connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
1600x900 60.07*+ 40.05
1440x900 60.07
1280x800 60.07
1280x720 60.07
1024x768 60.07
800x600 60.07
640x480 60.07
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)

So my monitor is eDP. That's also in the $DISPLAY system variable.

So you can set up a keyboard shortcut in Zorin menu > Settings > Keyboard Shortcuts (scroll to the bottom and click the  +  button)...

Name: Screen Off
Command: gnome-terminal -- /bin/sh -c 'xset -display $DISPLAY dpms force off > /dev/null 2>&1'
Shortcut:  Super  +  L 

If you're looking to save energy, you can turn the screen off and throttle your CPU back to its lowest frequency in the same keyboard shortcut... my machine only takes 26 watts at idle (and that's with 4 external drives, external speakers and my phone connected). The command to throttle back the CPU will depend upon which CPU you've got.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.