Main menu edit problem after installation

After I installed Zorin OS yesterday I couldn't add apps to the main menu. In the try out stage everything worked. I used the specific app for this but I couldn't confirm. Can you help me? It's not 100% necessary but it would be really nice if I could get a solution or if I can fix this.

i'm not sure I understand the problem correctly, but try start Menu editor via terminal.


See any errors poping up?

The problem is, that if I start the program and try to add an app, the "OK" button is not clickable so I can't add any app.

It indicate you might have filled out incorrectly information or missing something out.

Can you take a screenshot?

Not right now. My parents don't allow me. I could send details tomorrow. (Timezone UTC + 2 I guess)
I chose a name and a program path. Icon and description are unnecessary, right?


I'll send a screenshot tomorrow.

1 Like

You can also try menulibre instead.

1 Like

Does this open the same app?

It is the same functionality in a different app. It's worth trying out to see if you prefer its layout.

Okay. I will try the app out and take a look at it. If I like the look of the standard app more I will try to find a solution. I think I would look for it anyways because I want my system as optimal as possible.

1 Like

I tried it out but I always creates a new games category. I wanna add it to the existing games category.

Here is the screenshot.
Bildschirmfoto von 2021-08-25 08-00-27

May we see what command you trying to execute, it may be missing something.

It's the correct path to the app file.

But is it a .run .sh etc.?

No. Should it be?

I have to go for breakfast. I'll be back later.

To execute an app or script you need to tell how to do it.

If it's script, you can do

sh -c "<path>/<>"

I don't understand.