Main menu entry for shutdown logs me out instead

Hello, a new Zorin user here, I've recently installed Zorin on my desktop and I've enjoyed it so much that I wanted to use it on my old HP laptop.

Since the specs are not good enough on my laptop (low ram, weak CPU ) I opted for the lite version of Zorin, to my surprise it works well where others distributions could not even handle the screen without flickering and slowing the machine down to a halt.

I'm encountering a minor problem with the main menu entry for shutdown, I have the following entries for log out/locking and shutdown.


When I press the button for shutdown instead Zorin logs me out/locks screen.

This is the actual settings from the zorin menu editor:

These are my system info:

System Summary

Linux luca-HP-255-G7-Notebook-PC 5.15.0-91-generic #101~20.04.1-Ubuntu SMP Thu Nov 16 14:22:28 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: Zorin
Description: Zorin OS 16.3
Release: 16
Codename: focal

Thanks for any clue on how to "fix" this.

You are running Z16.3 Lite yes?
Question is because your profile is showing you have both Core (gnome) and Lite (xfce)

On my laptop I'm running the lite version( I added the kernel info in the post ) my desktop uses core that's why I have both.

And that's where I have this problem, on core I did did not find such issue, for now at least.

As far as I'm aware, the xfce4-session-logout command shows a prompt with multiple options to log out, power off, etc. Do you not see this? This is also the same behavior I have when I click on the "Shut Down" button from the menu.

1 Like

I tried it and no when the command is given to the shell terminal the screen goes black for a second and I'm logged out to the login screen.

Since the command is the same for the button the behavior is the same when I click it in the main menu.

Well, that's strange although I've found a few threads with similar issues on older versions of Ubuntu. It seems however that most of them are caused by something else that was installed. Have you noticed this issue from the very beginning or have you installed something in between?

For now, a quick workaround may be to open a terminal and type shutdown now.

1 Like

I cannot recall for sure, but as far I can remember this was happening from the beginning.

I don't know what could have interfered so much with this, apart from few programs obtained from the software centre and just few others from aptitude repos I don't had installed something that could be so invasive.

Maybe I did something without realizing, that's a possibility but I cannot think of what it can be.

If nothings help I guess I'll resort to the core edition.

Have you tried

sudo apt install --reinstall xfce4-zorinmenulite-plugin zorin-os-lite-desktop


Sadly it did not fix the problem, still the button behaves like before.

Have you installed any Screensaver or screenlocker or have you adjusted the screensaver settings at any point?

No I did not modify the screensaver section since installation, nor I got custom screen savers.

Can you show the lock screen tab?

Sorry for the wait, here it is.

Everything there looks right.

This is an odd one.

The Logout button is right next to the Shut Down button. The only thing I can think of is that the mouse cursor is being displayed off center of its actual position (Are you using a custom cursor or default?) or that the act of clicking the button actually bumps the cursor over to the left very quickly.

You might try testing with a different mouse.

The point is that I'm using it on laptop, on which I have both the track pad and a usb Bluetooth external mouse.

With both happens the same issue, and I'm not using a custom pointer I'm using the default one.

Oddly enough if you look at my very first screenshot of the main menu, if click on the lock icon it behaves like it should, so it's not something related to the cursor, it's related to somehting else, maybe I messed up the distro in some ways I cannot understand o maybe my HP laptop is cursed and hates linux ( not the first distro I had problems with ).

I have compared your screenshots with my HP 12" Elitebook running Zorin Pro Lite 16.3 and see differences. Looking at Screensaver, after 'Regard the computer as idle after' my notebook has another item:
'Inhibit screensaver for fullscreen applications on/off '. Turned off.
Then: Help. Power Management. Preview. Close.
On the "Screensaver Preferences" there is an extra item of 'User Switching on/off' which is turned on on my notebook.
The bottom section is different as well: Help. Power Management. Preview. Close. I wonder if there were updates that caused the changes? Very strange.
Or possibly items included in Pro, but not Lite.

1 Like

Further to my message above, I can only suggest you re-install Zorin Lite 16.3 with a new download from Zorin OS. I have three computers running Zorin Lite and have never had a problem like this. Perhaps try a different USB for installation. The slightly different layout suggests a problem with the installation. The other possibility from Aravision is a hardware problem, but you state the problem remains whether you use the touch pad or use the mouse. Usually Zorin Lite (XFCE) is very reliable.

Guess I managed somehow to disrupt/corrupt the installation/desktop env in some ways that are not known to me.

Anyway I guess I'll roll everything back after cleaning all partitions and start over again, thanks for the support.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.