Major issues with transferring files

I am having some pretty major issues involving copying larger files onto my laptop’s SSD. Here’s what happens:

Fresh install of Zorin Lite 16.2. SSD completely wiped beforehand, no dual boot or anything like that.

OS seems to work well, I configure it, run all updates, and am able to copy user library files over quickly - documents, pictures, music, some video files, etc. About 150GB of the SSD is now used including OS files. Everything seems working well at this point.

Now I would like to copy more video files over (about 1-5GB each), but the copying begins to slow way down, eventually freezes. I managed to slowly get about 50GB worth copied over, but the OS now seems totally bogged down. Everything is slow, even after restarting, to the point that it isn’t usable. If I open Firefox it will take a few minutes to open, then it crashes, etc. A previous installation stopped booting entirely, and wasn’t able to be repaired with Boot Repair, it required a fresh installation. Not sure if that problem was related to this one but I’m thinking it may be.

Here are things I’ve tried:

  • 2 different external drives - both are NTFS and connected through USB
  • Reinstalling the OS (multiple times)
  • Linux Mint (same issue)
  • Different file managers (Double Commander and whatever the default is on Linux Mint)
  • Some of the memory swap stuff suggested here:
  • Installing Caffeine and letting a single file transfer run all night (the system is either frozen in the morning or it shows the dreaded black screen with white underscore in the top left corner. Also strangely, after restarting, Caffeine is no longer installed..)
  • Transferring the files over the network instead of directly through USB using Warpinator
  • Deleting all the video files, emptying trash, restarting.

SSD is brand new, SMART scans show no problems. It has 1 TB capacity. I know it isn’t good to fill it up too much, but I would think the operating system should still function well with a less than half full drive. This laptop was previously working with all of the files on it on Windows. However it was running slow, one reason why I wanted to switch it to a light Linux. It does seem to run much better than it did on Windows, until I attempt the file transferring and it bogs down.

I think that either some hardware aspect of this laptop is failing, or Ubuntu doesn’t like it for some reason. It’s not a great laptop, and I will probably end up buying a new one once I’m able to.

I think I will do a fresh install of Zorin once again, accepting that I can’t transfer very many files, and leave it at that until I can get a better laptop.

But I’ve put enough time into messing with this that I’d love to figure out what is going wrong. If anyone has any thoughts or suggestions, I love to hear them!

Here is the inxi:

  Kernel: 5.15.0-69-generic x86_64 bits: 64 compiler: N/A 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Zorin OS 16.2 base: Ubuntu 20.04 LTS Focal 
  Type: Laptop System: ASUSTeK product: E402BA v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: E402BA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: E402BA.314 date: 02/26/2020 
  ID-1: BAT0 charge: 34.3 Wh condition: 36.8/36.8 Wh (100%) volts: 7.7/7.7 
  model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> 
  status: Not charging cycles: 100 
  Topology: Dual Core model: AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 11977 
  Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: ASUSTeK 
  driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
  Display: x11 server: X.Org 1.20.13 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.42.0 5.15.0-69-generic LLVM 12.0.0) 
  v: 4.5 Mesa 21.2.6 direct render: Yes 
  Device-1: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:15b3 
  Device-2: AMD Family 15h Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
  Sound Server: ALSA v: k5.15.0-69-generic 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: AzureWave driver: ath10k_pci v: kernel port: f100 bus ID: 01:00.0 
  chip ID: 168c:0042 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Local Storage: total: 6.37 TiB used: 206.85 GiB (3.2%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 870 EVO 1TB size: 931.51 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: XX scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Seagate model: Expansion HDD 
  size: 5.46 TiB serial: <filter> rev: 1801 scheme: GPT 
  ID-1: / size: 915.32 GiB used: 206.84 GiB (22.6%) fs: ext4 dev: /dev/sda2 
  System Temperatures: cpu: 62.0 C mobo: N/A gpu: amdgpu temp: 42 C 
  Fan Speeds (RPM): cpu: 3800 
  Active apt repos in: /etc/apt/sources.list 
  1: deb focal main restricted
  2: deb focal-updates main restricted
  3: deb focal universe
  4: deb focal-updates universe
  5: deb focal multiverse
  6: deb focal-updates multiverse
  7: deb focal-backports main restricted universe multiverse
  8: deb focal-security main restricted
  9: deb focal-security universe
  10: deb focal-security multiverse
  Active apt repos in: /etc/apt/sources.list.d/1password.list 
  1: deb [arch=amd64 signed-by=/usr/share/keyrings/1password-archive-keyring.gpg] stable main
  Active apt repos in: /etc/apt/sources.list.d/zorin.list 
  1: deb focal main
  2: deb focal main
  3: deb focal main
  4: deb focal main restricted
  Active apt repos in: /etc/apt/sources.list.d/zorinos-ubuntu-apps-focal.list 
  1: deb focal main
  Active apt repos in: /etc/apt/sources.list.d/zorinos-ubuntu-drivers-focal.list 
  1: deb focal main
  Active apt repos in: /etc/apt/sources.list.d/zorinos-ubuntu-patches-focal.list 
  1: deb focal main
  Active apt repos in: /etc/apt/sources.list.d/zorinos-ubuntu-stable-focal.list 
  1: deb focal main
  Processes: 184 Uptime: 13m Memory: 7.22 GiB used: 1.35 GiB (18.7%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17 
  running in: xfce4-terminal inxi: 3.0.38 

Thank you!

This looks like a dirty files problem with your cache.
Essentially, you cache is overflowing, then the system pauses to try to deal with that.
Which can get messy.

I remember that there is a fix for this, something with /proc/sys and a file in there... But I do not remember off the top of my head and it is now 1:10 am here so I am going into a coma. If the above did not get you pointed in the right direction for a Net Search - I will run one later when I am more alert and willing to get mired into something.:wink:


Ah, interesting. I tried a couple things related to that, but didn't quite understand it. I'll take another stab at it.

The cache should be reset once the computer is restarted though, right?

1 Like

Thanks, I tried sudo sh -c "sync; echo 3 > /proc/sys/vm/drop_caches" and that seemed to help somewhat... At least the system became more usable than it was, so this is good to know.

However, there definitely still seemed to be something wrong - the main symptom being that any changes I made (changing Firefox settings, adding shortcuts to the dock, installing applications) would not persist after restarting.

I ended up reinstalling once again, this time I have only transferred a minimal amount of files over. I'm going to try using it for a week or so like this, and see how it goes.

You might do

mv ~.config .config-bk

Reboot, set all your customizations... then reboot and see if they remain. There may be a corruption in your ~/.config folder.

EDIT: Just read that you reinstalled... Well... note to future self.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.