Make a browser default

Hi there!

First of all i'm new here. Have the Pro edition. :slight_smile:

I have a small problem. I deleted the bundled FireFox with Zorin. And i did install a new FireFox from store, the flatpak version. Also installed Brave Browser flatpak from store.

Neighter of them will be my default browser, you press set as default browser, nothing happens. How to fix this issue?

1 Like

You may have better results if you used the apt (not flatpak or snap versions) of browsers, as flatpaks and snaps are self-contained and may not interact fully with the rest of the system.

You should be able to find the apt version that you used to have as part of bundle (currently v108 when I just checked) available in the Software store listed as Firefox Web Browser (source ubuntu-bionic-updates-main).
Remove the flatpak version to avoid having two FF apps installed.

3 Likes

Did you check this settings page :point_down:?

1 Like

I had assumed that is what the OP had done to try and set FF as his default browser. Your question is valid if my assumption was wrong.

@Emil please clarify, how you tried to set default browser.

3 Likes

Probably in the most common way, so from its own settings page and enabling the setting that say to make the current browser as default.

@Emil, would you tell me why you replaced your preinstalled Firefox? Just to see if I guessed the reason, nothing else.

Hi.

Thanks for answers!

I can change the browsers to default as Luca shows. But when i go into the browser settings it states that the browser is not the defalt browser, it goes for both Brave/FireFox.

@Luca_Pavan

No reason for browser change. Just wanted the flatpak version, more system secure and faster updates. :slight_smile:

1 Like

Maybe this is stupid, but did you try setting your favorite browser as default browser both on its own settings and Zorin settings (on the section shown on my first message)? Just to be sure there's no “settings conflict” :smiling_face:.

I have seen other posts recently from people unable to set flatpak/snap apps (e.g. VLC player) as default apps. I bet it is the same problem. One of many reasons I don't use flatpak/snap versions of apps myself.

2 Likes