Make password to login zorin when i open pc

I have password to sudo and when came back from suspend or logout, but when i open or start pc I login without password, how i make pc open with the password?

Do you have auto-login enabled?

i don't know, where i can check that?

Check the contents of /usr/share/lightdm/lightdm.conf.d/60-zorin-os-lite.conf and see if there is any autologin entry listed.

1 Like

If you're still using Gnome, settings - users - click on your user. You should have to enter your password to make changes. Toggle the auto login

1 Like

that is the content
[Seat:*]
user-session=zorin-os-lite

I don't know, but i'm using xfce, not gnome.

Interesting... and you say that you must enter password for Login from screenlock, but not on start up?

I don't use XFCE, but doing a search there seems there is no option to turn that on and off in a gui. I found this though:

LightDM GTK Greeter Settings will save setting in /etc/lightdm/lightdm-gtk-greeter.conf and has no options for autologin true/false or on/off because the settings for that are in /etc/lightdm/lightdm.conf

So, remove your name from the line 126 to be like this
autologin-user=
or comment the line
#autologin-user=

1 Like

I did a lot of stupid and radom things since i began using linux, I don't remember that things, i think may be i didn't set password during installation zorin, may be i set for user, but not for root, i don't know, I have used seahorse before for problem with keyring browser

I have noticed you have some of the more interesting threads.
Is a Fresh Re-installation an option?
I know when I first started using Linux (Zorin OS), I ended up reinstalling a lot due to my explorations. Now, it is very rare I need to do that.

1 Like

Zorin doesn't work that way, you only enter 1 password at the time of install.

I don't know if any distro's still do that, I think many of them got rid of it. When I first started using Linux we had 2 passwords one for Root and one for the User that we created at the time of install.

What you could also try is since you only mentioned suspend/logout, restarting, then at the login screen selecting Zorin Desktop (Gnome) instead of XFCE, go into the user settings toggling the autologin there, then restarting. In theory, it should fix the configuration file.

I would take @Aravisian suggestion and do a re-install. I used to have to re-install quite often in the beginning. This is what having a /home partition is so important.

I'm new in linux, I think I have been using linux for less than 3 month until now.
I have bad experience with fedora that is the first distro i tried, I was doing re-installation every day, because every time i face problem , i do re-installation.
if I do a fresh re-installation i will need to re-install my apps again?

Please see;

1 Like

that worked for me, autologin was enable, so i disable it
nano /etc/lightdm/lightdm.conf
image

1 Like