Managed to get admin account without a password but can't leave password prompts empty

Greetings all.

I was successful in creating a admin account leaving it's password blank (so updates and software downloads can be done as these can't be done on an account without admin access)

But issue is to download or update anything the password prompt dosent accept an empty password even though there is no password.

This laptop has absolutely no sensitive information on it whatsoever so I would really prefer just leaving out all passwords (can login automatically but I often put the laptop to sleep very frequently and having to put in a password every time is annoying. Which is strange as it automatically logs in without asking for password when booting)

How do I disable passwords or make it automatically login when the laptop is awoken from sleep just like it does when booting?

I'm a new user with absolutely no experience with Linux whatsoever and just can't use a terminal. Chat bots don't help as all I get back are error messages... I have no clue what I'm doing.

Thanks in advance for any help.

Hello, and welcome!

It would be good to know what you did on their behalf, just to see if something that wasn't broken before needs fixing now. You see, these things are designed to make stuff up as they go.

There are a couple of ways to go about doing what you're after, but I don't think this can be done entirely using a graphical interface. I'm sure you can at least understand this is for a very good reason.

Search in the applications menu for "Terminal" and type the following command:

passwd -d zenzen

Replace "zenzen" here with your actual user name. I don't think it will be needed, but If you get an error regarding permissions, try again like this:

sudo passwd -d zenzen

This should be enough to delete the user's password. You can now log out and log back in and see if that works.

Welcome to the Forum!

When You go to the Settings and there to Your User Profile You can set there an automatic Login:

If I'm not mistaken, this would still require a password when you return from sleep. The only solution that I've found is to completely delete the user password.

2 Likes

Thank you everyone for all your replies. Will try all this but was thinking to just do a fresh install to play it safe (any ideas how to get to BIOS? Windows was "esc" but don't have windows 8 anymore) from flash to play it safe. Unfortunately got warning last time about 14 file errors in the flash when doing it in the bios.

If I should have to recreate the flash and download Zorin OS again (maybe I'd choose Zorin OS lite this time to perhaps have faster boot and better battery life ony laptop?) I'm stuck as I no longer have access to Rufus which was on windows which I deleted. But if possible I'd prefer to avoid this as downloading an over 3GB ISO at 20 Kbps is very taxing and exhausting.

Also how do I disable unresponsive scrolling? (I take my fingers off the scroll pad but no matter how slow I scroll, it continues to scroll and even worse no matter how gently I take my fingers off the scroll pad it often scrolls up. It's annoying where I actually have to put in significant effort to "aim" and still fail as I scroll)

As I want to exclude Libre office apps for security and recommend updates. Only reason I'm updating is I had my under login freeze on me once and had to struggle to get it responsive again (power button on and off a few times which just put computer in and out of sleep)

This is vendor-specific, if you were using ESC before it should be the same; the BIOS loads much sooner than the operating system so that is not relevant.

If you don't have the USB with Zorin OS Core anymore, or want to use Zorin OS Lite, then I'm afraid you will have to download it. Check out the different available mirrors and choose one that is closer to your physical location, that might help a bit.

You can follow the instructions on how to create a bootable USB drive for Linux. Another option not mention in the help page is Ventoy. I only suggest this because people have reported issues with Balena Etcher breaking the USB drive while burning the ISO.

I can't comment on the scrolling issue but regarding Libre Office you can uninstall it afterwards. To save a little bit of time (as you mention you have slow download speeds) you should choose not to install updates during installation. Then, remove Libre Office and run the updates. Remember that it'll take a while anyway but Libre Office is a large suite of software so this will shorten it.

Thanks for your reply. I still have Zorin OS core on my flash stick but when installing last time the bios said 14 files have errors but I'm hoping a simple update replaces the error files?

Regarding the scrolling I heard it's similar to the MacBooks called momentum scrolling or something.

Do You mean this Self-Test what appears when You start the USB Stick?

Thanks Ponce-De-Leon

This is the message. Just decided to reinstall Zorin OS core completely as I have no idea what damage I did with the chat bot telling me to write in the terminal.

Yes, that is the Self-Check. And that these Files are not okay, could be a Problem, yes. It don't have to. But I think it would be a safer Way to download the ISO again.

And when You did that control the Checksum from the ISO, too. This one is on the Zorin Website listed:

2 Likes

Reinstalled Zorin OS core

Started installing/downloading brave and removing Firefox... Software went into a never ending loading screen using up a lot of my limited (but very large) data plan.

Tried force closing softener, rebooting... No good.

Updated Zorin OS

And see brave is installed somehow but dosent open. Get this message when trying to uninstall brave

Going to try second reinstall but this time connect to internet while installing Zorin OS to get the updates and software it said it needed while installing to save time.

The Software Store is indeed slow, and sometimes unstable. I would recommend using another package manager with a graphical frontend called Synaptic. Of course you need to install it somehow, but one easy way to go through the command line is:

sudo apt install synaptic

Now, as for the error message it looks like it has something to do with Snap. This is a packaging format for software used by Linux, one of many anyway. It's not uncommon to have issues with these... Brave Software themselves admit this much about these packages.

I can only suggest you try to use the native option available, labeled as "Zorin OS" right under the big blue installation button. For Brave specifically, it won't be there by default and you'll have to download it from their website directly (link above, just scroll all the way up). If the download doesn't start automatically use the command line for Debian/Ubuntu, entering the commands one at the time. Don't worry, is not nearly as scary as it looks like.

2 Likes

That is a Snap Problem. You should try to take the Flatpak Version or You add the Brave Repo to use the .deb Version.

You can make that, sure. But it can bring Problems, too when something doesn't work. It don't have to but to install it without Internet Connection could cause less Problems. But it's up to You. When You want try it, try it. And when it works ... that is what matters.

1 Like

Did this as seen on screen and now seems everything is working (still not sure what was going on but brave browser installed). Thanks for the help everyone.

1 Like

Was able to create admin account without a password by creating a new user account and leaving the password field blank (create password now but leave blank)... Only issue is to update or download anything, it dosent accept nothing typed in.

I could just remove the main user account with the password but I fear I will not be able to get back into user account settings to create a working admin account when I should need it.

Did you already try to run the passwd -d zenzen command?

Apologies not yet.

Will this remove it asking for a password? As I can already create an admin account without a password in the standard user account settings.

Using space as a password isn't so bad anymore. Gotten used to it.

Yes, this will effectively make the user account to become "passwordless". The only time where you will be asked to enter a password is at the login screen, but that's because of how the login screen itself works; you can press enter with an empty password and it will log in. You can, if you want, setup automatic login separately to avoid this step as well.

Of course, I would prefer and recommend to have something in place. At the very least, an innocent attacker i.e., your little cousin or something, might give up rather soon even if pressing space is all it takes.

2 Likes