Matebook D15 is not gettin sound with zorin os 17

There is for alsa information :
http://alsa-project.org/db/?f=41a47949683c0a71893e40960b6da7ea5bf5dd1b
I try alsa mixer is just show this:


Please someone help me

Welcome to the Forum!

Did You tried the PulseAudio Control? It is a Program for set up Sound Output and Input. To install it, open the Terminal and type sudo apt install pavucontrol

Yes , this say is the hdmi/display port is unconnected


and show the all profile is unconnected

I have just done many websearches using "Matebook D15 Intel Tigerlake HDMI Ubuntu 22.04" and find none that help fix no sound. Some people on later Ubuntu report the same problem with this hardware.

I did see one that said plugging in headphone caused speaker to work, but I would put that down to witchcraft, which sound issues on linux often conform to in my experience.

Have you tested running Z17 from Installation Live USB in "Try Zorin" mode?

Other options would be later linux kernel, or test a more bleeding edge linux distro.

One post said sound worked on opensuse distro.

Some related dialogue re D15 and Linux can be found here: https://www.reddit.com/r/Huawei/comments/hmra1o/huawei_matebook_d15_linux_compatibility/

I had this ''unconnect'' int he Past one time, too. But for me it was enough to click on the green Marker to set it as my Fallback and then reboot my PC and then it was detected and connected.