Mediatek MT7630e wifi working intermittently

Hi there, I recently installed Zorin on my Asus laptop and for some reason the wifi worked for about 5 minutes and then stopped locating any networks. I’ve reset the laptop and every once in a while the networks in my neighbourhood show up, but after a while they drop out. It’s not a placement issue as I can be anywhere in my house and it still gives the same issue where sometimes I see the wifi and sometimes I don’t. (Other wifi hardware in the house works fine and when I had Windows installed on this laptop it worked fine as well)

I’m using an Asus laptop with a Mediatek wifi adapter installed. I’ve researched all the forums and tried every suggestion that I could see and it still does not stay consistent.

Please help.

Thank you.

$ inxi -Fxrz
System: Host: my-laptop Kernel: 5.4.0-47-generic x86_64
bits: 64 gcc: 7.5.0
Desktop: Xfce 4.14.2 (Gtk 3.22.30) Distro: Zorin OS 15.3
Machine: Device: laptop System: ASUSTeK product: TP500LA v: 1.0 serial: N/A
Mobo: ASUSTeK model: TP500LA v: 1.0 serial: N/A
BIOS: American Megatrends v: TP500LA.203 date: 06/11/2014
Battery BAT0: charge: 20.2 Wh 99.8% condition: 20.2/48.3 Wh (42%)
model: ASUSTeK TP50042 status: Not charging
CPU: Dual core Intel Core i5-4210U (-MT-MCP-)
arch: Haswell rev.1 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
clock speeds: max: 2700 MHz 1: 1012 MHz 2: 1568 MHz 3: 1541 MHz
4: 1308 MHz
Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.20.8 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.03hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
version: 4.5 Mesa 20.0.8 Direct Render: Yes
Audio: Card-1 Intel 8 Series HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Haswell-ULT HD Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k5.4.0-47-generic
Network: Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8169 port: e000 bus-ID: 02:00.1
IF: enp2s0f1 state: down mac:
Card-2: MEDIATEK MT7630e 802.11bgn Wireless Network Adapter
driver: mt76x0e bus-ID: 03:00.0
IF: wlp3s0f0 state: up mac:
Drives: HDD Total Size: 500.1GB (1.7% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 457G used: 7.1G (2%) fs: ext4 dev: /dev/dm-0
ID-2: swap-1 size: 1.02GB used: 0.00GB (0%)
fs: swap dev: /dev/dm-1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 37.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0

Do you see any drivers listed for your adapter under System Tools -> Software Updater -> Settings -> Additional Drivers?

Any solutions here work?