MediaTek MT7922 wifi stopped working

I've been running Zorin on this Asus Vivobook for about 6 months without issue. Booted up this week to find no wi-fi. Ethernet still functional and detect no other device issues. Other than routine updates, I have not installed, changed or uninstalled any apps. Wi-fi works fine in Windows 11.

lshw -c network reports the wireless adapter as unclaimed.

I run Zorin from a Fit drive with Windows 11 running from internal drive. Fast boot is disabled. After trying web search suggestions, I did another separate install on an identical Fit drive with the same result. I then tried an install of Ubuntu 22.04 just to see whether that would work. Same failure.

Had the wifi never worked with Zorin, I would not be as puzzled, but I'm not sure where to go from here.

I'm still a Linux novice, but can follow commands and have decent knowledge of computer hardware.

Have you tried rolling the kernel back?
Boot into Grub Menu, then select Advanced Options for Zorin and arrow key down to an earlier kernel and select it to boot. Test if Wifi is working.

1 Like

@Aravisian: Thanks for the reply. I did try all of the kernels available in the advanced menu (5.15.0-75, 5.15.0-76 and 5.4.0-153). None worked. 5.4 would not even boot. Also attempted the recovery modes. So far, no luck.

Gday @Fletch , Welcome to the community!

Can we please see the output of the "Network" results, copy & paste or screenshot.

Can we also get you to open "Software Updater"
let it load up, then click the "Settings" button,
This will open "Software & Updates" 1st open the TAB "Other Software", please select the "Canonical Partners" ( just the first one unless you also use/want the "source code" aswell).
The open the "Addition Drivers" TAB, & let it search/load, see if there is a driver for the Wifi, if so select & apply.
Then run the "Software Updater" after applying any changes.

Can i also ask, do you have "Fast startup disabled?
if not follow this guide please.
How to disable Fast Startup
If you needed to disable the Fast Startup, it is suggested to then run the Windows update after doing so.
Then re-enter Zorin OS & again run the updater.
Keep us informed.

@Ocka: Thanks for your reply

-Screenshot attached for network.
-Canonical Partners was already selected.
-There was no driver available on the Additional Drivers tab. The only drivers there are Nvidia drivers. No apparent drivers for wifi card.
-Fast Startup was already disabled (I disabled it at the beginning of this troubleshooting effort).

Let me know if you need any other info.

Thanks again.

Still have not found a solution to his issue. If anyone has other suggestions, please offer them up. In the meantime, I did buy a cheap USB wifi adapter to get by. If anyone encounters an issue with their Mediatek (or other brand) wifi like I did, here is a product that works out of the box and was only $10USD.

1 Like

Final update. It turns out that my MT7922 was defective...or evil. Though it has continued to work with Windows, it has started to exhibit other problems. For instance, it did recently stop connecting in Windows 11. I was able to reset it using a 60 second press of the power button, but even then there were issues. Finally, when it stopped allowing me to cast to my TV in Windows, I decided it was time to give up.

Replacing it with a different adapter has fixed everything and even fixed something I hadn't attributed to the wifi card; trackpad stuttering. The built-in trackpad in my notebook has been stuttering in Zorin from day one. But, since replacing the wifi card, it stutters no more.

So, if you've stumbled across this post with the same or similar issue, spend $25 on a new (not Mediatek) card and you will be fine.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.