Mediatek Wifi + Bluetooth MT7921 not working

I just installed Zorin 16 on my new Acer Aspire 7 with a Ryzen 5 and a GTX 1650. Out of the box, my wifi adapter is not found and bluetooth doesn't turn on. It works with an external USB adapater. Can someone direct me as to what I can do to find the drivers?

lshw output

  *-network UNCLAIMED
       description: Network controller
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm cap_list
       configuration: latency=0
       resources: iomemory:fc0-fbf iomemory:fc0-fbf iomemory:fc0-fbf memory:fcd2000000-fcd20fffff memory:fcd2100000-fcd2103fff memory:fcd2104000-fcd2104fff

(1)

Please go into the BIOS to be sure that you have SECURE BOOT disabled. If its already disabled, and your still having issues, then we may have to move onto step......

(2)

CTRL ALT T to enter terminal

lspci

Please post the results here please. Basically, we need to find out if there is a driver that can be downloaded for your WIFI. Usually drivers are already in the kernel, but we may still need to download one.


Hey, thank you for getting back to me.
a) Secure boot has been disabled. I did that before installing Zorin.
b) lspci output:

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
	Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
	Flags: bus master, fast devsel, latency 0, IRQ 42
	I/O ports at 2000 [size=256]
	Memory at d1504000 (64-bit, non-prefetchable) [size=4K]
	Memory at d1500000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
	Capabilities: [170] Latency Tolerance Reporting
	Capabilities: [178] L1 PM Substates
	Kernel driver in use: r8169
	Kernel modules: r8169

04:00.0 Network controller: MEDIATEK Corp. Device 7961
	Subsystem: Lite-On Communications Inc Device 3802
	Flags: fast devsel, IRQ 255
	Memory at fcd2000000 (64-bit, prefetchable) [disabled] [size=1M]
	Memory at fcd2100000 (64-bit, prefetchable) [disabled] [size=16K]
	Memory at fcd2104000 (64-bit, prefetchable) [disabled] [size=4K]
	Capabilities: [80] Express Endpoint, MSI 00
	Capabilities: [e0] MSI: Enable- Count=1/32 Maskable+ 64bit+
	Capabilities: [f8] Power Management version 3
	Capabilities: [100] Vendor Specific Information: ID=1556 Rev=1 Len=008 <?>
	Capabilities: [108] Latency Tolerance Reporting
	Capabilities: [110] L1 PM Substates
	Capabilities: [200] Advanced Error Reporting

Its possible your internal adapter is not going to work under Linux, this happens more often then you think when hardware is only made for Windows, as no drivers were made or released for Linux users.

However, one thing you can try, is install Blueman Bluetooth Manager from the Software Store. Its from the Blueman group, youll see that on the page, to know you selected the right one.

Install that, and see if you can turn the adapter on with Blueman. You will probably have to restart, Blueman will let you know. If Blueman can't activate your wireless adapter, then nothing can in Linux.

If this is the end result, then us, you will have to rely on the wireless USB dongle in the end.


1 Like

Also when manufacturers go for cheap and use some fly-by-night components for things like networking cards and the like since most users are Windows users and won't notice the missing Linux support.
By the time anyone realizes, that little fly-by-night company changes its name to some new company and keeps on lying.

This is a problem with ODB II adapters and readers and with USB sticks, too.
For example, cheap USB sticks are often programmed to lie and claim that they are a larger capacity than they can physically hold.

3 Likes

I always test my USB memory and microSD as soon as it arrives in mail with this application:

This article is from 2015. It is still relevant.
https://www.happybison.com/reviews/how-to-check-and-spot-fake-micro-sd-card-8/

3 Likes

Tried to used the Blueman Bluetooth Manager. Didn't change anything. Guess I'm stuck with the USB dongles for now. Thanks for your help!

You can wait for the kernel update.
Apparently it will work in kernel 5.14 and up.
We are using kernel 5.11.

See the second answer.

Oh yeah, I tried manually upgrading the kernel to 5.14 when I realized this one didn't have the drivers. That created issues with the nvidia driver. Looks like waiting for the kernel update is the way to go.

1 Like