Mega desktop apps dependencies on Zorin 16

Good morning

I have a problem, i'm trying to install but it occours everytime the same error: "The following package have unmet dependencies".... i'm trying all version from 2 days but doesn't work... I've installed gdebi... but nothing

now I find this method, mega was installed from the store and it works... but with the nautilus megasync when I download from home site of mega: appears the same error "The following package have unmet dependencies"

please help me

zorin is the only os that work fine on my pc

thanks have a good time

What version did you select ? Zorin OS 16 is based on ubuntu 20.04. Make sure to select that one.

1 Like

Welcome to the community.

You may want to install synaptic. sudo apt install -y synaptic

Open it, search mega and when you select it the dependancies should auto select for install. Install and enjoy.


I also had a problem with Mega desktop app a few days ago.

It is not exactly the same problem as yours, but at the end I realized that web interface works much better than the desktop apps. I now uninstalled Mega apps and using web interface only.

Thanks to everybody

i've tryied all version 20.04 and others... Nothing

I've tried synaptic... when i search mega there are only 2 name " megadown " and "mega tools" but i need the " sync for nautilus " for automated download and upload when i move file from documents

Does it list the missing dependencies?
You also may try installing the .deb file from terminal with sudo dpkg -i megasync-xUbuntu_20.04_amd64.deb
sudo apt install ./megasync-xUbuntu_20.04_amd64.deb

See if the terminal prints out the missing dependencies.

Another thing to try:
Open Software & Updates, on the Download From option, select Main Server
Then in terminal run:

sudo apt update && sudo apt full-upgrade

Once complete, try installing the mega .deb file.


when i run sudo dpkg -i megasync-xUbuntu_20.04_amd64.deb exit error message: Impossible to axcess to archive "megasync-xUbuntu_20.04_amd64.deb": File or directory doesn't exist

When i run: sudo apt install ./megasync-xUbuntu_20.04_amd64.deb
E:File ./megasync-xUbuntu_20.04_amd64.deb not supported passed on line command

and try sudo apt update && sudo apt full-upgrade i repeat the firsts command but nothing :frowning:

Please check the actual name of the package that you downloaded.
It should be the Ubuntu 20.04 package, as shown in @Michel 's post here:

Strange thing is that I do not have Mega desktop app in my Software.

[quote="Fatez94, post:7, topic:11984"]
sudo dpkg -i megasync-xUbuntu_20.04_amd64.deb

sorry i'm italian this is what terminal give to me

the name of program is right

tell me if you don't understand from photo

very strange... this is a photo from my zorin store


1 Like

That explains it.
I am not so sure if it is a good idea to mix FlatPak with deb installer.
I think this FlatPak should be removed before deb installer.


the English translation is: Selected nautilus-megasync package not previously selected.
(Database reading ... 302056 currently installed files and directories.)
Preparations to extract nautilus-megasync-xUbuntu_20.04_amd64.deb ...
Nautilus-megasync extraction (3.6.6) ...
dpkg: dependency problems prevent nautilus-megasync from being configured:
nautilus-megasync depends on megasync; However:
The megasync package is not installed.

dpkg: error processing nautilus-megasync (--install) package:
dependency problems - left unconfigured
Libc-bin trigger processing (2.31-0ubuntu9.2) ...
Trigger processing for hicolor-icon-theme (0.17-2) ...
There were errors in processing:

I think your problem is preexisting FlatPak version of Megasync.
Nautilus integration cannot work with Flatpak.
You should remove Megasync desktop app in Flatpak before the installation of those deb files.

flatpak uninstall [program name]

1 Like

oook i've uninstalled :wink: .... And now ?

This will give you info on installation methods

Tutorials & Guides : Differences Between Snap, AppImage, and Flatpak

1 Like

Do you still have those downloaded deb files?
Use gdebi to install Mega desktop app first.
Then install Nautilus integration.
You cannot flip this order.


I believe this is it.
The user had a Flatpak Megasync, so the .deb installer could not see that the dependent Megasync was installed.

I really feels Flatpak and SNAP added so much confusion especially for the beginners. It is ironical since those new installers were developed to make Linux easy for the beginners.

Appimage is a different kettle of fish since it is a cross platform for Linux, Windows and macOS.