Mega upload cannot see any files

For a change I now need to ask for a help from the fellow forum members.

I tried to upload files to Mega but it could only see folders not files.
Does anyone have the same problem?

I made sure that I have the latest Mega and Nautilus integration apps I downloaded from the official site:

Just tried it, uploaded a folder, it's working ok.

1 Like

I thought I could upload any file from any folder.
But when I click "upload" in Mega menu, I could only see folders and no files are showing. Do I misunderstand how this works?

Screenshot from 2021-11-22 22-41-03

Just wanted to ask you if it was the cloud folders or local drive. But I know now what you mean. But no I have no problems. Just tried it again and the files are all visible.

Did you just installed it and are trying to use it just now?

1 Like

I have been using Mega for over one year.
I just noticed today that I cannot upload from the Mega menu.

I accessed to my account online.
The same thing happened. I cannot see any files in my local directory.

That is strange
I guess you checked it already and confirmed there is enough space to store the files.

Yup.
I also tested it with MS Edge. The same thing happened. I cannot see any local files.

I also checked within VM Windows. I could see files there.

It got be something to do with my current installation of Zorin.
I will check it with my sub-machine which is running Mint.

[edit]
Test completed.
It is working fine in Mint Debian.

I might have to go back to my older Clonezilla back up image.

1 Like

Your fast, glad you figured it out. Hope you don't loose much data while restoring.

1 Like

My data is backed up almost daily. It is a separate operation from Clonezilla.

Just out of curiosity, I also checked dropbox.
Everything is file there.

It seems the only problematic combination is
current Zorin installation + Mega

I wish I know what caused it.
I did not install anything new for last couple of months.

@Aravisian
Do you have any idea what might went wrong with my installation?

  • Zorin + Mega is not working (desktop apps, Firefox and MS Edge)

  • VM Windows guest on the same machine + Mega is working

  • Zorin + Dropbox is working

  • On other machine Mint + Mega is working (i.e., nothing wrong with my Mega account)

1 Like

I just opened Megasync and everything is present and accounted for.
This suggests that it is not Zorin OS causing the issue, but your build of Zorin OS that is affected.

Have you removed and purged the megasync application and reinstalled it?

2 Likes

I did it in gdebi.
But I did not purge it.
I will try.

[edit]
I completely remove and purge Mega desktop app.
Now I can see my files at Mega website.

I am still puzzled what really has happened.

Since I am not a heavy user of Mega, I will do without desktop apps and use it online only.

2 Likes

I also have found the installed app to be less than stellar. The browser function always works fine.

1 Like

Thanks for this additional observation.
I tested web UI and as you said, it works better than the desktop apps.