Microphone doesn't work over browser applications, with no error message

Hi, I've recently installed Zorin OS on my mom computer.

Everything was fine until I tried to make a meet (Google Meet, Zoom or Jitsi Meet, same result) over Chrome.

The browser ask me to give permission to the web camera and the microphone, and that’s what I did.

There was no error on the screen, but on the other side no one was hearing my voice.

Double check the browser permissions for the mic ... was OK.

I increased the mic volume, and all I get was a noisy background.

Reading on many forums I found that there is an inversion issue between the internal microphone and the external.

I've tryed several options:

  • Enable the internal audio monitor in the pavucontrol app, and mutting the right side channel ... did't work.

  • Download and install the alsa-hda-dkms package looking to mute the "Inverted Internal Mic", but I can't see the inverted internal mic in Alsamixer.

  • Something actually did work, but the fix get lost when I restart the browser (and obviously also when I restar the whole computer) was, with the Alsamixer open, make the set and unset de external mic from pavucontrol app. It make it work into de Chrome.

  • I added in the /etc/modeprobe.d/alsa-base.conf these two properties:
    options snd_hda_intel model=laptop
    options snd-hda-intel position_fix=1 enable=yes
    Didn't work

  • I created new file /etc/modprobe.d/blacklist-local.conf and add the following line in it:
    blacklist snd-soc-dmic
    Didn't work

The audio information in the output of lspci -vv command is:

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- SERR- <PERR- INTx-
Latency: 32, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 130
Region 0: Memory at b1320000 (64-bit, non-prefetchable) [size=16K]
Region 4: Memory at b1300000 (64-bit, non-prefetchable) [size=64K]
Capabilities: [50] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
Address: 00000000fee00358 Data: 0000
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

I uploaded the alfa-info output log file in the link below:

Thanks in advance for any help you can give me.