Microphone from headphone is not recognized


I'm using Zorin Os 16 in a dual-boot with Windows 10.
I have a headphone which I plug into my laptop in a P3 entry (sound+voice).

In Windows 10, when I plug it in, it asks "what device are you using?" and then I select "headphone with microphone" (or something like that, don't know how to translate it correctly, but basically it is output+input), and then I can speak through my headphone.

In Zorin, the sound works fine, it is coming out of the headphone. But the microphone is not recognized. My Zorin keeps using the laptop's microphone, which isn't very good. How to make it use the headphone microphone? It isn't listed in the "input" devices list.

I will kindly appreciate your help.

I don't have the headphone model because it is a very cheap 1 dollar headphone.

Here's the output of inxi -Faz if it helps.

inxi -Faz
  Kernel: 5.11.0-38-generic x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-38-generic 
  root=UUID=89bbb2e1-499d-4e30-a612-4daf59a26a94 ro quiet splash 
  Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3 
  Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal 
  Type: Laptop System: Acer product: Nitro AN515-44 v: V1.04 
  serial: <filter> 
  Mobo: RO model: Stonic_RNS v: V1.04 serial: <filter> UEFI: Insyde v: 1.04 
  date: 02/04/2021 
  ID-1: BAT1 charge: 58.3 Wh condition: 58.6/58.8 Wh (100%) volts: 17.4/15.4 
  model: SMP AP18E7M type: Li-ion serial: <filter> status: Unknown 
  Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600103 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 92621 
  Speed: 1315 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 
  1: 1386 2: 1288 3: 1455 4: 1397 5: 1266 6: 1395 7: 1357 8: 1229 9: 1388 
  10: 1395 11: 1388 12: 1397 13: 1397 14: 1396 15: 1456 16: 1469 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA vendor: Acer Incorporated ALI driver: nvidia v: 470.63.01 
  bus ID: 01:00.0 chip ID: 10de:1f95 
  Device-2: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu 
  v: kernel bus ID: 05:00.0 chip ID: 1002:1636 
  Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati,nvidia 
  unloaded: fbdev,modesetting,nouveau,vesa compositor: gnome-shell 
  resolution: 1920x1080~144Hz 
  OpenGL: renderer: NVIDIA GeForce GTX 1650 Ti/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes 
  Device-1: NVIDIA driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 10de:10fa 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Acer Incorporated ALI driver: N/A bus ID: 05:00.5 
  chip ID: 1022:15e2 
  Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 05:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.11.0-38-generic 
  Device-1: Realtek vendor: Acer Incorporated ALI driver: r8169 v: kernel 
  port: 2000 bus ID: 03:00.0 chip ID: 10ec:2600 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 2000 
  bus ID: 04:00.0 chip ID: 8086:2723 
  IF: wlp4s0 state: up mac: <filter> 
  Local Storage: total: 476.94 GiB used: 60.86 GiB (12.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN530 SDBPNPZ-512G-1014 size: 476.94 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> 
  rev: 21103900 scheme: GPT 
  ID-1: / raw size: 34.33 GiB size: 33.54 GiB (97.70%) 
  used: 18.14 GiB (54.1%) fs: ext4 dev: /dev/nvme0n1p5 
  ID-2: /home raw size: 98.76 GiB size: 96.71 GiB (97.92%) 
  used: 42.05 GiB (43.5%) fs: ext4 dev: /dev/nvme0n1p6 
  ID-3: swap-1 size: 1.91 GiB used: 625.2 MiB (32.0%) fs: swap 
  swappiness: 10 (default 60) cache pressure: 100 (default) 
  dev: /dev/nvme0n1p7 
  System Temperatures: cpu: 67.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: nvidia screen: :0.0 temp: 42 C device: amdgpu temp: 42 C 
  Processes: 398 Uptime: 5h 04m Memory: 7.15 GiB used: 4.37 GiB (61.1%) 
  Init: systemd v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Shell: bash 
  v: 5.0.17 running in: gnome-terminal inxi: 3.0.38 


I think we need @zabadabadoo for his Alsamixer expertise.

@arcstur This may involve a bit of trial and error testing.
Open terminal Ctrl+Alt+T. Then type alsamixer
Check Alsamixer is showing your correct sound card. Hit [F6] to show them all.
Have a look at your mic channel settings.
Make sure none of them are set Muted i.e.[MM]. You step across and unmute by typing M. Also increase the levels to max.

You could try toggling Loopback and see if that helps. Also Auto-mute. Have a play around with Alsamixer and post back your results, preferably with a screenshot of your Alsamixer screen.

Good luck. Sometimes sound issues need a bit of that.


I use Pulse Audio myself to select INPUT/OUTPUT devices, and their volumes. I also have an extension to do it quicker in the taskbar as well. If what Zaba suggests doesn't get you going, you could always try Pulse Audio.


Your Tech Support Guru


I used to use Pulse Audio in my linux mint. Here in Zorin, here's what happens:

In "Output Devices":
headphone unplugged: "Speakers"
headphone plugged: "Headphones (plugged in)"

In "Input Devices":
headphone unplugged: "Microphone"
headphone plugged: "Microphone"

It doesn't change.

Is that what you see in pavucontrol?

Here's the screenshot from alsamixer


Tried messing around but the mic still isn't recognized.


Can you open Alsamixer and hit [F5] to show all audio channels (not just [F3] Playback channels as per above screenshot),

then post another screenshot.

Also go to Auto-Mute and toggle that to "Disabled" and see what happens (if anything).

Sure! Here it is:

(p.s.: sorry for the delay in responding, I'm not receiving desktop notifications somehow)

Is that really everything, i.e. nothing more to the right on that screen?

yes! nothing more

On Channel 4

@StarTreker Please explain.

You can disable the built-in sound chips in the BIOS setting.
I have a high-end USB DAC for my desktop and sound chips are disable at BIOS level.

I understand now.
You want to use an external microphone connected to 3,5mm jack.

@arcstur Is your headphone via 3.5mm jack or USB?

Also in alsamixer what sound card/s do you see when you hit [F6] ?

Are you able to increse levels for those 2 [Mic Boost] channels 5 & 6

Personally, I use Pulse Audio APP when I want to make audio settings changes. It does all I need to do. It allows me to select which input microphone I want to use, what output I want to use as well.

I think if this Alsa strategy fails, we could try that alternative method.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.