Microphone input also picks up all system sounds

I use an Arturia MiniFuse 2 audio interface to connect my microphone and headphones to my computer, but the microphone input in Zorin also captures system audio. This happens both in the live environment and my local installation. The issue does not occur in Windows, so it must be a software issue.

pavucontrol lists two (relevant) inputs:

  • Monitor of MiniFuse 2 Analog Surround 4.0 -> Includes only system audio, as expected.
  • MiniFuse 2 Multichannel -> Includes both my microphone's input and system audio. This should only include my microphone.

Interestingly, the sound settings menu has my Output Device set as MiniFuse 2 (as expected), but the Input Device is blank, and does not list any MiniFuse-related devices. I can still record my voice in Sound Recorder using the MiniFuse, though.

How can I separate my microphone and system audio?

I have done a little more testing and the same issue occurs on another machine with Zorin 17 installed. I dual-booted Manjaro on that machine and it works as expected, so it's definitely something wrong with either Ubuntu or Zorin.

Is there anything I can copy from the Manjaro installation to make this work? Some config files maybe? I don't know where to start looking.

The place to start looking should be /etc/pulse/ , /etc/modprobe.d/ , and /etc/asound.conf .
I am not sure beyond that since I have never really used Manjaro nor have a copy I can quickly boot into.

Also check if you have a ~/.pulse folder (ctl+hwhile in home directory will reveal hidden system files).

I don't have an /etc/asound.conf file or a ~/.pulse directory on either system, and there are no files in /etc/modprobe.d on Manjaro.
I've just tried copying the /etc/pulse and /etc/alsa directories from Manjaro into Zorin (yes, I backed up the existing stuff) and rebooted, but the same issue still occurs.

It's not looking good :confused:

I may try installing Ubuntu 22.04 LTS tomorrow to see if it also happens there.

We also may be barking up the wrong tree... If it is not a configuration issue, but a package issue.
I believe that Manjaro uses Pipewire by default whereas Zorin OS relies on Systemd's Pulseaudio.

Pipewire may be a promising avenue to explore.

Perhaps, but I appear to also have PipeWire installed already. I haven't installed it manually and I have a very minimal setup right now so I assume it came pre-installed with Zorin 17? I would assume that if it comes pre-installed then it should be in use by default, no? Or do I have to fiddle with something else first?

In any case, I do like the idea of PipeWire. I'm not exactly sure what the differences between Pulse/ALSA/PW and which can be used with each other (or if they all do the same thing) so I may have to do some more digging on that.

Although not a solution, I stumbled on this whilst doing websearch on "Arturia MiniFuse 2 audio Ubuntu". Supported Audio Interface Information - LinuxMusicians

If I find anything of use I will edit or post again.


Sorry, I found nothing of use.

1 Like

I found the source of the issue and a workaround!

I noticed that the system audio being played through the input was lower in volume, which I thought was weird. It definitely wasn't leaking through my headphones, or it would have sounded tinny. This led me to wonder why the interface was presenting itself as a 4.0 surround device considering that it's only supposed to be stereo. On a whim, I moved the sound output fade slider all the way to "Front", and it stopped feeding through system sounds! I assume the extra 2 channels the MiniFuse presents are some kind of internal loopback?

This isn't a perfect solution, however. It still doesn't present itself as an input device in the Settings application (despite working just fine), and the fade slider doesn't save its position if you reopen Settings (but it continues to work as if it was). Functionally, it's perfect. But the user experience is definitely not good.

1 Like

Does Zorin Settings>Sound show that device as surround or stereo?
Is there a drop-down with stereo option?

Open alsamixer in terminal.
Have a play with alsamixer channel settings to identify those that correspond to the unwanted rear channels and mute them i.e. select and hit "M" key.

Save good alsamixer setting (if you find one) using:

sudo alsactl store

Does Zorin Settings>Sound show that device as surround or stereo?

In there it shows as "Analog Output - MiniFuse 2" with a slider for left/right balance and a slider for front/rear fade. pavucontrol's Configuration tab it shows it as "Analog Surround 4.0 Output + Multichannel Input".

Is there a drop-down with stereo option?

No. The output device dropdown only shows a single option for the MiniFuse 2 and the others are my onboard audio and GPU audio.

Open alsamixer in terminal.
Have a play with alsamixer channel settings to identify those that correspond to the unwanted rear channels and mute them i.e. select and hit "M" key.

I can't. Opening alsamixer and selecting the MiniFuse just shows this message: "This sound device does not have any controls."

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.