microSD Card Not Mounting

So I have a scandisk memory card which I record videos on. It used to work fine using a USB adaptor to open it and extract the files. But now it wont open or even let me reformat the card. It does detect that it is there but I just can't do anything with it. Any ideas how to fix this. It is not just this card it appears to be all my memory cards and they do work fine on all other devices.

Is it mounted? Usually double clicking will mount it, but then while it's mounted you won't be able to format it... you have to unmount for that operation.

1 Like

Rosa, you posted a while back, I think, wondering if it was your SD adapter.
This guide suggests that a driver is needed and gives the step to install it:

I am not sure if this issue is the same as yours.

So I tied this but this was the what come up in the terminal

rosa@rosa-Build:~$ sudo apt-get install exfat-fuse exfat-utils
[sudo] password for rosa:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package exfat-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package exfat-fuse
E: Package 'exfat-utils' has no installation candidate

Can you check the repository:

sudo add-apt-repository universe

sudo apt update

Then try exfat-utils again?

sudo apt-get install exfat-fuse exfat-utils

I tried this and it had the same outcome. I am guessing it no longer exists so there must be a different solution.

1 Like

That's odd.

I searched for other solutions; you can try this posters offered solutions that are toward the bottom of the page where he or she proposed three different solutions:

That is not working either.

What about testing other Linux distros to see if it is indeed a Zorin specific problem. You can use a Live USB for that purpose.

Also, please remind; what computer (year make and model) are you using? It seems like whenever you have some troubleshooting, it is far more intensive lol.
I recall the internet stubbornly refused fixing, too.
Maybe there is something particular about your machine.

1 Like

It is one that I built myself this year.

Having said "it used to work fine", need to think what has changed. I don't think anyone has so far suggested verifying the hardware involved instead of going down the path of software and drivers. I can remember another thread recently where the problem was traced to a failed adapter (hardware).

@Rosa Are you able to establish whether the card works on its own plugged in another device and/or checked that particular USB/SD adapter with another SD card?

Yes it works fine on my other computers both a Mac and Windows. What I have been doing is transferring to a hard drive then transferring it to my linux computer but it would be so much easier if I could directly transfer it to my directly instead of this round about way. And it is the same USB port I use on the harddive so I think it has something to do with it not being able to read the card, which is weird because it used to do it fine.

Yes, this is Rosas second thread n this particular issue. In the first one, FrenchPress helped troubleshooting hardware and the last we knew in that thread, Rosa said she would look into that. Some time passed, then this thread began.
I believe the SD card is for Photography work, so transferring it from a camera to a Cloud, then to the Zorin computer, is not possible, leaving the round about way described above. As an eBay seller, I have dealt with similar until I got a "smart" (heh heh heh... smart...) camera that connects to the web; in fact it even allowed me to link it to eBay to upload from the camera to eBay directly.
I think you are right, Zaba. Hardware can do funny things and lead you on a merry goosechase often. I cannot count how many times some rubbing alcohol and a q-tip cleaner on the electrical contacts Fixed The Issue.

Software side- the only clue is that Zorin is the only machine it is not working on and while this does not eliminate hardware, by any means, if installing exfat worked, that would be easier than buying or disassembling hardware.
Dunno why it isn't... it works fine on mine:

This also suggests something software side...

By the way Rosa, Are you set to Main Server in Software and Updates?
Also, checkmark ON the options
Propirietary drivers (restricted), software restricted by copyright or legal issues, if they are not already.

@Rosa What filesystem is the SD card formatted?
Has it been recently re-formatted? (i.e. since last time it worked on your linux computer for instance)

1 Like

I'm in line with zabba, maybe the usb is on its way out and Linux is more particular to hardware failure symptoms than other os's. Remember the hard drive issue on another thread of this forum... windows could access but it seemed to be having corrupted data or sectors preventing access. This could be the same, only usb thumb drive. Concept is the same but the physical is different.

Have there been any power spikes or brown outs in your area? Do you have the power saving for usb turned on in power options? Changes in voltage could effect the usb long before it does damage to the rest of the computer. Ram is just as susceptible.

2 Likes

Remember, Rosa has a microSD plugged in a USB adapter then plugged into a USB port. So there are 2 hardware components in addition to the linux computer USB port itself. It would be good to carry out a process of elimination on these 3 items of hardware.