Microsoft organization account cannot seem to be removed?

I've been using my personal ZorinOS computer to connect to a work oranization Microsoft account, especially for Teams, both the installed app and in browsers (Edge and Chrome). Now I'm no longer with this organization and I need to remove the account, because I need to access other Teams meetings with my personal Microsoft account. However, every time I try to access or log into the Teams desktop app, it forces me to access as my former organization's domain, showing me their logo/picture.
In Zorin>Settings>Accounts, I have no trace of this. In Edge settings I cannot find it either.
Does anybody know how/where to remove this dirty M$ trace?! Thanks!

Hello and Welcome to the Community.
For, your teams app, run this in terminal -

sudo apt --purge remove teams

Can you then run dpkg -l | grep -i teams and share the output.

EDIT- I didnt read, you already tried checking Settings/Accounts. Anyways, the above command should work.

Thanks, I did it but Teams is still there with the same issue. Even if I choose "Sign out and forget" from the login screen for my former work/org e-mail address, the domain and logo/picture from my former work/org is still there.
dpkg -l | grep -i teams outputs nothing for me (not even an empty line).

can you tell me what was the output of this ? sudo apt --purge remove teams.
And, try this instead - dpkg -l *team*

The output of the apt remove is gone, sorry. I remember it did remove something... but I think I had 2 instances of Teams desktop app (maybe 1 flatpak and another snap or something else).
Now if I try it again I have the error that I does not manage to find the package (because I removed it earlier) :
E: Unable to locate package teams

flo@floZorin16:~$ dpkg -l *team* Desired=Unknown/Install/Remove/Purge/Hold | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad) ||/ Name Version Architecture Description +++-==================-============-============-==============================> un libteam-utils <none> <none> (no description available) ii libteamdctl0:amd64 1.30-1 amd64 library for communication with>

If I check the remaining Teams desktop app it seems to be the flatpak version, checking ps aux | grep teams once I run it:
/usr/libexec/flatpak-bwrap --args 52 teams

Yeah. The Confusion was because it has a .deb version, a snap version and flathub version and I didnt know which one you had.
flatpak remove flathub

Ok thanks, I uninstalled it:
flo@floZorin16:~$ flatpak remove flathub
Warning: flathub is not installed

ID Branch Op

1. [-] stable r
Uninstall complete.

Now, which version would you recommend I reinstall? I would avoid the flatpak since I have a hard time managing these apps in my VPN's split tunnel rules (all flatpak apps seem to have to follow the same rule, which does not work for me).

Also, in my browsers there is still the same kind of stuck work/org imposed domain that I cannot seem to be able to bypass... any idea where/how to remove it? I usually preferred the browser version of Teams because there were more advanced features than in the desktop app.

DEB version by far.


Looks like it's not available anymore, I tried to get it but I cannot find it.

Any help for the browser version?

You will need Chrome or a Chromium based browser to access the Teams PWA.

Looking at the mess created, I would recommend you backup all useful files and create a new Zorin User Account with admin access and delete that old User and then load back the backup files.
This time you dont have to sign in to your organisation account. Since no other version is suitable for your situation, download snap version here sudo snap install teams-for-linux

Ok thanks, it worked, both after re-installing the snap desktop app, and via the new PWA.

Now my issue is that if I need to join another organization's meeting as an external, it seems my free account isn't enough... as if I would need to pay Microsoft to just join a Teams meeting organized by a company I'm not a part of. Me, giving $$$ to M$. Ouch.

I dont think i can help with that nor am i matured enough to give you real life advices(i just got 18 yo this april). Still I think you should reach out to that other organisation about this issue.
If you face any other technical issue regarding zorin, you can open a new thread about it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.