"Minimal BASH-like line editing is supported ..." error

I want to have dual boot on my new computer with Windows 11 on it. So I tried to install Zorin OS on another drive. Somehow the Zorin OS installer messed up the boot configuration. When I boot the machine I get this cryptic message from GRUB: "Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywere else TAB lists possible device or file completions." The Zorin installer has also removed the Windows boot manager so I can't boot Windows anymore.
I've read the It's FOSS article on this problem and followed the guide to reinstall grub, but without any luck. I also tried to run the Boot Repair tool twice, but that didn't work either. I still get the same error. I can try to install Zorin OS again, but I won't really learn anything by doing that. Does anybody know how to solve this problem without reinstalling Zorin OS?

Here is the beginning of the text file Boot Repair generated:

============================== Boot Info Summary ===============================

=> No boot loader is installed in the MBR of /dev/nvme0n1.
=> No boot loader is installed in the MBR of /dev/sda.

nvme0n1p1: _____________________________________________________________________

File system:       vfat
Boot sector type:  FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  Zorin OS 16.2
Boot files:        /boot/grub/grub.cfg /etc/fstab

nvme0n1p2: _____________________________________________________________________

File system:       ext4
Boot sector type:  -
Boot sector info: 
Operating System:  Zorin OS 16.2
Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub

sda1: __________________________________________________________________________

File system:       vfat
Boot sector type:  FAT32
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  
Boot files:        

sda2: __________________________________________________________________________

File system:       ext4
Boot sector type:  -
Boot sector info: 
Mounting failed:   mount: /mnt/BootInfo/sda2: /dev/sda2 already mounted or mount point busy.

sda3: __________________________________________________________________________

File system:       ntfs
Boot sector type:  Windows 8/10/11/2012: NTFS
Boot sector info:  No errors found in the Boot Parameter Block.
Operating System:  Windows 7

Seeing that your Windows is showing on sda, is it on an SSSD? The fact that Zorin appears to be on SSD suggests that Windows is on HDD which in turn suggests possible corruption of the systems partition table. I would disconnect/remove the drive with Zorin on and see if you can boot into Windows.


Hi.Zorin is on a NVMe disk. Windows is on a SSD. Haven't disconnected the NVMe from the motherboard with Zorin on it yet. Shouldn't be necessary and I don't see why that would help. Tried to install Zorin again. Didn't solve the problem.

The Zorin OS installer has no ability to remove the Windows bootloader.
I assure you that the Windows Bootloader is in place.

What is the size of your EFI partition?

Did you install one as Legacy boot and the other as EFI boot?

In your BIOS Settings, are you set to RAID or AHCI?

In your BIOS Settings, is Secure Boot enabled?

In your Windows OS, Control Panel > Power Settings, was Fast Boot enabled prior to Zorin OS Install?

1 Like

Hi. Yes, you're right, the Windows bootloader is not really removed. It was clumsily formulated. What I meant is that when I press the boot option key on the computer the Windows bootloader is no longer on the list. When I choose the disk Windows is installed on, the machine reboots and I get the same "Minimal BASH-like line ..." message again. If I choose the disk Zorin is on, the machine reboots and starts Zorin fine. It’s the only way to get the machine started. My point is that clearly something went wrong under the installation of Zorin. Even a reinstall of Zorin won’t correct the problem. I don’t feel like removing the NVme disk on the motherboard so I’ll probably start with Windows recovery/reinstall since the Zorin installation can’t correct the problem.

The size of the EFI partition is 537 MB

Both systems are installed as EFI

Bios settings are set to RAID on

Secure boot is disabled

I don’t know if fast boot was enabled in Windows because it was as fresh install and I only checked if the system was working before I started to install Zorin.

This is actually the first major problem I’ve encountered with Zorin OS. I love Zorin, it’s my daily driver.

All of this looks ok. The EFI partition is big enough.
I doubt that Zorin OS mangled the Windows Bootloader. I am not passing the buck here, either. If I thought it had, I would bluntly say so and be offering suggestions on how to fix it.
Rather... I think it is Windows where the problem is. Not due to Windows hate, just an acknowledgment of the facts.
Windows isn't to blame, either.
The supplier of the computer is.
Microsoft did not install Windows on that computer. The supplier did and the supplier had their own interests at heart when they did so.
Do you have access to a Windows LiveUSB or Disk?
If so, or if you can get one:

Use the bootable media to boot the PC.

On the Install Windows screen, select Next > Repair your computer.

On the System Recovery Options screen, select Troubleshoot> Advanced options >Command Prompt.

Now type diskpart hit enter.

Type the following commands and hit enter: select disk 0
0 is the disk on which Windows is installed.

Now type list partition and hit enter.

Note the partition on which Windows is installed

Type select partition # and hit enter.

Note: # is the number of the partition on which Windows is installed.

Now type active and hit enter.

Restart the PC.



This new Dell computer I've bought is the WORST computer I've EVER had. The Windows repair your computer doesn't work. The Dell online recovery tool doesn't work - of course. Now I can't even install Windows. I'm at loss to know how I can fix this computer. I've dealt with many computer problems in my life, but I think this is the first time I have to give up. i don't even know what the issue is since none of the tools will give me any clues. I think maybe the UEFI firmware somehow got corrupted, but it has to be more to it than that since I can't even install a fresh copy of Windows on it without getting an error: "Windows could not prepare the computer to boot into the next phase of installation. To install Windows, restart the installation." Which I did and got the same error again. I seem to be stuck in an installation limbo ...

It may be a BIOS malfunction/bug that causing this. Have you try to flash the BIOS with the latest version?

1 Like

This stuff here - this is why I left Windows completely behind when I migrated to Linux, via Zorin OS.
It was a struggle learning a new OS. I had never used Linux before that.

But the above? Yep.
Windows tells you next to nothing.
In Linux, the terminal tells you what went wrong. It even offers suggestions as to how to fix it.
Windows automates it all with GUI functions... that are non-verbose. Like the network troubleshooter.
You open it since net is not working and it gives a whirly gig... either it works or it doesn't. If it doesn't it says, "Sorry... can't." That's it.

Keep the user ignorant to keep the supplier in control.
Then, you gotta pay them to fix it.

Hi. I didn't flash the BIOS, but I restored it to factory defaults. I then continued to install Windows for the third time. The previous attempts to install Windows had left several boot partitions in addition to system OS partitions. I deleted all of the partitions before installing. After that is was smooth sailing. Windows 11 installed without any problems and more importantly, Zorin OS also installed without any problems on the NVme drive. The original GRUB error is gone and I have the dual boot system I want. Sadly I'm not any wiser to what the original issue was and why it escalated and made my computer completely unusable.

I agree wholeheartedly, Linux is the superior system. But in fairness, I think some of the problems I encountered could've been caused by hardware or firmware issues not related to Windows. Maybe some user errors too :slight_smile: Anyway, everything is working like I intended now.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.