Missing Module libavahi-dev for HPLIP Install

Trying to install hplip-3.21.2.run

Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name Component Required/Optional
libavahi-dev scan REQUIRED

I have done a search online and cant find this module at all. I seem to remember that someone said I had to use something like g2Scan. Is this correct?


You can install it as 'Ubuntu' instead of 'Zorin.'
Doing so should avoid looking for libavahi-dev as it is not used in Ubuntu.
That is used in Suse Linux.

If you absolutely need libavahi-dev, we can install it.

To install it: Grab the .rpm package here;

Packages in .rpm format will not install on Debian or Ubuntu based systems. But there is a Converter for that: Alien.

sudo apt install alien

Once installed, you can open terminal in the directory that your .rpm package is in. For example if it is in Downloads, cd ~/Downloads.
Alien is a CLI app only. Run in terminal as (replace with the actual package name):

sudo alien -d .rpm

That will create a .deb file that you can double click to install.

Thanks for the help.

I got this error.
sudo alien -d libavahi-devel-0.8-alt1.aarch64.rpm
libavahi-devel-0.8-alt1.aarch64.rpm is for architecture aarch64 ; the package cannot be built on this system

See what happens when I get into a big hurry? Good thing that at least this one didn't involve C-4.

Try this, instead:

1 Like

All done and installed perfectly.

Thanks a bunch. I have just come back to Linux and love that I can get great support from a real person and it makes sense. I have been on Windows for the last 15 years and it is so frustrating at times.

1 Like

Did you try unplugging it, hitting it with a hammer, inserting a grilled cheese sandwich and then plugging it back in?

1 Like

You have mentioned the same issue as Cannot Get Hplip 3-21.2 Installed - #5 by carmar
Since this thread has been marked as solved, that thread will be closed. Please do not cross-post in the future.

There are a number of issues that i have created per problem. They are all linked to HPLIP-3.21.2. So what did I do wrong?

HPLIP-3.21.2 is one package you're having problems installing. The reason for these two threads to exist is because you're trying to get that one package installed.
If I were to post, I would have HPLIP-3.21.2 as the sole topic, with all problems listed there. In your other thread you had a permission issue which would predate the dependency issue. You could have continued the thread indicating that you have solved the permission issue (you did not indicate that on the other thread but it is the logical conclusion given that you started this thread with a dependency issue) and now have a dependency issue.