Missing Wifi Drivers and Adapter

I just upgraded to pro and it seems to have wiped my wifi out? I have no wifi card installed according to Zorin and the slot is listed as unallocated. I have tried varios fixes but none seem to have worked. My wifi card is an Intel Wifi 6 AX201 card. It seems driver installation in Linux is harder than windows for sure! Plus, the system won't allow me access to paste driver files into the /lib/firmware folder!


Was it working in the free versions of Zorin?
Also, about pasting driver files to that folder, system folders require admin privileges, so you would need to do it directly from the terminal:

right click on the folder where the driver files are, click on "open in terminal" and type:

sudo cp (name of the file) /lib/firmware

then try turning off and on your pc and see if that fixes the issue

1 Like

Hi Sorro
After hours of searching the internet and various failed workaround, I found this Chinese site (link) that had a simple work around that fixed the issue.

The Driver was working fine in the free version, but on Pro upgrade it seemed toi have wiped it. The few lines of commands here look to have reinstalled the iwlwifi driver. One for the Devs maybe for future releases?


1 Like

If problem is now fixed, can you click the "Solution" checkbox under your post, if that link was the solution. Thanks. Zab

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.