MOK error while trying to change OS

I wanna change os but this MOK thing won't let me boot up mint. I've been using Zorin for a while now and it's great and looks great, however it's kinda slow and i really hate the very slow slow file manager. Pls help. I have no idea what I'm doing, i only switched to linux because my laptop windows broke for i who know what reason. Zorin is great, but just not for me.

You chose to encrypt your installation? I have not done this, but @Mr_Magoo may be able to help. He should be along in a bit. He runs zorin encrypted with zfs.


I had no idea what exactly i was doing. I just followed the instructions shown to me in the installation part to enable my nvidia(mx130) gpu. I'm really sorry. Need help. :smiling_face_with_tear:

ZFS isn't encryption, it's a type of file system. It can be encrypted, but I don't have it encrypted.

As to the MOK, you should be able to just select "Continue Boot". MOK (Machine Owner Key) authentication is used when SecureBoot is enabled, to ensure only owner-approved files load.

If you choose "Continue Boot", then Linux will attempt to get MOK working after you've booted... it'll likely pop up a similar dialog box asking for the MOK passphrase.

Either enter a MOK passphrase (be sure to write it down so you remember it) in your UEFI / BIOS, then enter the same passphrase in the blue-screen shown in the images above, or disable SecureBoot in UEFI / BIOS.


Secure Boot is for Windows Only. If you are not dual booting with Windows, You are best to have Secure Boot disabled. It is useless on Linux and only gets in the way or even blocks some applications from working.


Interesting, I wonder if it's right the reason about some games on my laptop :thinking:.

1 Like

I dual boot with Win 10 but I believe I disabled Secure Boot and haven't had any problem when ever I use Win 10 which is very rarely ..... next time I open my computer I'll check just to be sure ..... :thinking:

1 Like

I think i understand this???
I'll assume you had secure boot "Enable" when you first installed Zorin !!
And this is Not Dual boot, or trying to setup dual boot with Mint. ( Just clean install to new clean install )

If correct: There can be a couple of thing happening here.

  • The MOK error maybe due to a corrupt installation of Mint with corrupt SHIM( Bad download/installation device). Test installation device for error's , checksum the Download.

  • From memory
    Installing Arch OS is one of VERY few Linux Distro's that you need to "Disable" secure boot
    To install Arch.

On the other side of the coin,
Some manufactures will not let you install with secure boot disabled.

Can you tell us the machine brand & model?
And let us know how the results of the test's on the installation setup.

1 Like

I found the solution after searching for a while. I disabled the secure boot. By running the sudo mokutil --disable-validation, reboot then change the secure boot to off and entered the password i remembered. but I'm gonna stick with zorin for a little longer. The devs might make an update soon. thank you for the help guys, your the best. sorry bad english.


it's an Acer aspire a515 53g - corei5 8thgen with nvidia mx130 gpu. and only 4gbs of ram. Zorin feels kinda sluggish in this laptop i dunno why.

1 Like

Glad to see your sticking around :+1:
Great to see you've fixed the issue. Good Job.

Keep informed About Updates via Subscribing to their news letters.

Thank you.
On behalf of the,
Zorin forum community.!

Title: changed.


I can confirm my Secure Boot is indeed turned off ..... and Ocka sent me this command so I don't need to open Win 10 to see if Secure Boot is enabled or disabled ......

sudo mokutil --sb-state

Thank you my friend ..... it works beautifully ....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo mokutil --sb-state
[sudo] password for mike:
SecureBoot disabled


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.