Monitor not detected and is not showing (Sceptre brand)

I just installed zorin os because i wanted to try out linux, but the monitor is not detected and is not showing. I ran xrandr and nothing shows up about a second monitor at all. I run on a laptop and I am just typing this on it's screen.

It says the *-display thing twice and the information on it. So the os knows that it is there. My laptop screen is intel while the monitor is nvidia. Could this be the issue?

[sudo] password for me:
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
logical name: /dev/fb0
version: 01
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=i915 latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
resources: iomemory:620-61f iomemory:400-3ff irq:173 memory:6204000000-6204ffffff memory:4000000000-400fffffff ioport:4000(size=64) memory:c0000-dffff memory:4010000000-4016ffffff memory:4020000000-40ffffffff
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: iomemory:600-5ff iomemory:620-61f irq:16 memory:5f000000-5fffffff memory:6000000000-61ffffffff memory:6200000000-6201ffffff ioport:3000(size=128) memory:60080000-600fffff

Sorry I have no idea how to do this stuff, but how could I downgrade the driver? Thanks for your help so far.

okay (I need 5 characters so here are some more)

I tried some different drivers and it is connected, but now its is just a black screen. The monitor is connected and I can move my mouse to it and see the mouse on the other screen but it is completely black.

You can launch Software & Updates app from the main menu. Then navigate over to the Additional Drivers tab. From here, you can select a different Nvidia Driver and let it "install".
Once it completes (It can take a moment), you will need to reboot the computer to use the newly selected driver.

If you are connecting the monitor with an HDMI cable, many HDMI cables are Unidirectional - meaning they only work one way. If an HDMI cable is not working, try disconnecting it and turning it around.

Nvidia can be inhibited by the option Secure Boot being enabled in BIOS. Secure Boot is for use with Windows. So, if you are not using Windows (dual boot) on that machine, you do not need to have it enabled. You can disable Secure Boot in the BIOS EFI Settings prior to booting Zorin OS.

Well the whole screen is black, though it shows in settings and everthing now. I can see my mouse on the screen

Do you know what model of Nvidia card it is? For example the GTX3060 or the 1050TI?

I have no idea. I did some more tests. I put a youtube video partly on the black screen and can play the video without seeing it.

What is the terminal output of

uname -r

and also install neofetch (sudo apt install neofetch) and post the output of


for uname -r

And the result of Neofetch?

When you boot and look in the grub menu - advanced options for Zorin - do you have a list of multiple kernels?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.