Monitor refreshes when playing video, skipping etc

Hello all, just made the switch to Zorin 16 from WIndows and i'm having an issue.
I experienced this issue on Ubuntu as well before installing Zorin.
My graphics card is a AMD Radeon RX 5500 XT 4GB and the system is AMD Ryzen 5 3600.
Whenever I start a video on youtube, scroll by a video on facebook feed or anything video related starts playing my monitor refreshes, turns off for a second or two and turns back on. If I skip ahead in a video it does it each skip. Also when Steam is open even in the background, it refreshes my monitor every 30 seconds or so randomly. Pretty annoying to say the least. I have one of the Onn brand monitors from walmart that I thought could be the issue but it never did that with Windows and i've also tested it on my TV etc and it does it with every monitor. My PC only has 1 HDMI out.
I see Zorin is supposed to have all the AMD drivers installed already so not sure what to do, or if its even a graphic driver issue or not.
Any leads appreciated. Thanks

Also loving Zorin so far minus this issue.

Please check if the updated Graphics drivers help:

sudo add-apt-repository ppa:oibaf/graphics-drivers

sudo apt update && sudo apt full-upgrade

AMD is tricky. The company openly states they support Open Source and provides some open source drivers. But they also keep some of their drivers as proprietary.

1 Like

Thanks for the reply.
I tried this and it installed 18 packages. Rebooted and still has the issue so didn't work unfortunately.

What is the output of

uname -r

Also, the output of


Headed to work now but will update this evening after trying these. Thank you.

1 Like

Just a side note. Please check your Software Updater is set to point to "Main Server" not a regional server.
Could you also edit your forum profile to indicate which edition of ZorinOS 16 you have e.g. Core, Lite etc.

1 Like

uname -r
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 0.00*
1366x768 0.00
1280x720 0.00
640x480 0.00

This looks like your graphics driver is not loading.
What is the terminal output of

inxi -Faz

Command 'inxi' not found, but can be installed with:

sudo apt install inxi

Yes, please install it.


Kernel: 5.13.0-27-generic x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-27-generic
root=UUID=0977d40c-ef79-4a71-9446-ff5d1253858a ro radeon.si_support=0
amdgpu.si_support=1 radeon.cik_support=0 amdgpu.cik_support=1
Desktop: Gnome 3.38.4 wm: gnome-shell dm: GDM3
Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Type: Desktop Mobo: ASRock model: A320M/ac serial:
UEFI [Legacy]: American Megatrends v: P4.20 date: 08/02/2021
Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen
family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021
L2 cache: 3072 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 86243
Speed: 2196 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz):
1: 2196 2: 2189 3: 2193 4: 2196 5: 2196 6: 2196 7: 2194 8: 2194 9: 2194
10: 2195 11: 2196 12: 2192
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] vendor: Gigabyte
driver: N/A bus ID: 09:00.0 chip ID: 1002:7340
Display: x11 server: X.Org 1.20.13 driver: ati,vesa
unloaded: fbdev,modesetting,radeon compositor: gnome-shell
resolution: 1920x1080~N/A
OpenGL: renderer: llvmpipe (LLVM 13.0.0 256 bits)
v: 4.5 Mesa 22.0.0-devel (git-b5b105d 2022-01-21 focal-oibaf-ppa)
direct render: Yes
Device-1: AMD Navi 10 HDMI Audio vendor: Gigabyte driver: snd_hda_intel
v: kernel bus ID: 09:00.1 chip ID: 1002:ab38
Device-2: AMD Starship/Matisse HD Audio vendor: ASRock
driver: snd_hda_intel v: kernel bus ID: 0b:00.4 chip ID: 1022:1487
Sound Server: ALSA v: k5.13.0-27-generic
Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
v: kernel bus ID: 04:00.0 chip ID: 8086:24fb
IF: wlp4s0 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel port: f000 bus ID: 06:00.0
chip ID: 10ec:8168
IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac:
Local Storage: total: 1.38 TiB used: 33.73 GiB (2.4%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HAJQ-000L7
size: 476.94 GiB block size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 serial: rev: 5L2QEXA7 scheme: MBR
ID-2: /dev/sda type: USB vendor: Western Digital model: WD Elements 2621
size: 931.48 GiB block size: physical: 512 B logical: 512 B
serial: rev: 1026 scheme: MBR
ID-1: / raw size: 476.44 GiB size: 467.96 GiB (98.22%)
used: 33.73 GiB (7.2%) fs: ext4 dev: /dev/nvme0n1p5
System Temperatures: cpu: 47.4 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 338 Uptime: 1m Memory: 31.28 GiB used: 1.19 GiB (3.8%)
Init: systemd v: 245 runlevel: 5 Compilers: gcc: N/A Shell: bash v: 5.0.17
running in: gnome-terminal inxi: 3.0.38

Let's try some grub parameters.

sudo nano /etc/default/grub

Find the line:
After the word splash you can add the parameter. In this case, let's try pass-through. Make it look like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amd_iommu=on iommu=pt"
Once the change is made, ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.
The terminal will revert to normal.
Now, you must run:

sudo update-grub

Reboot and test. If the above does not work, try:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amd_iommu=off iommu=pt" and remember to sudo update-grub to make the change take affect and test.

alright so the first grub line change fixed the issue when I click on a video directly in youtube, no refreshes. But for instance if I hover over a video in google, it refreshes. Odd.

Tried the second grub line you mentioned instead and it was back to where it was, all refreshes on any video playing.

Looks like we are on the right track, at least.
I need to be away from the computer for a while, but will continue later.

no worries! and i agree. Again I appreciate the help so far. Means a lot.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.