Monitor won't wake after dpms force off until logoff/reboot

Problem:

When running the command xset dpms force off , it will turn off all the monitors into standby mode. But if I move the mouse and see the flickering on the second monitor, and then execute the command again, the monitors will be unrecoverable with mouse or key input unless I log off with ctrl+alt+del (and wait 60s) or sysreq reboot. Sometimes switching to TTY session with shift+alt+F3 turns on the monitors, but it also ends my previous session.

Example:

  1. Execute xset dpms force off manually or by trigerring gnome-screensaver and wake the monitors with mouse/keyboard.

  2. Repeat until a partial mid-portion of my second monitor flickers.

  3. When the second monitor is flickering, run the same command again.

  4. Monitors won't wake up from mouse or keyboard input. Even after rebooting the monitors physically.

  5. Accept fate and restart the session/pc with ctrl+alt+del or REISUB kernel reboot.

Why turn off the monitors?

I've used Click Monitor DDC in windows that allowed me to turn off all monitors manually via taskbar. It was more convenient than locking the session while allowing me to sleep.

Troubleshooting

In Zorin, I usegnome-screensaver-command --activate as a custom keyboard shortcut to trigger the screensaver. I thought that gnome screensaver would fix this issue, results are the same.

I'm running Nvidia Geforce GTX 750Ti with Nvidia proprietary 540 driver. With two monitors hooked up with DP (165hz) and HDMI (60hz).

I need help figuring out why it happens, I couldn't find any cause nor any working fix from either ubuntu and nvidia forums. (or maybe because I couldn't explain this problem better)

Purging and reinstalling the Nvidia 540 driver didn't fix. I'm using 540 version because it's the driver that my games run best with wine.

I like everything else about Zorin OS so far, but this issue made me want to turn back to windows for the time being.

Please let me know if you have a suggestion, thankyu ^^

Welcome to the Forum!

Did You tried to change from Wayland to Xorg? If not, go to the Login Screen and click on Your Profile so that the Password Field appeares. It must appeared! When it is appeared, you shouldsee in the bottom right Corner a Gear Icon. Click on it and You should see 2 Options:

Zorin Desktop (that is the Wayland Option)
Zorin Desktop on Xorg

What is active You can see on the Dot Marker.

echo $XDG_SESSION_TYPE reports x11

I couldn't see any options at login screen.

Okay, I see. That could be because of Your NVidia Card. Did You tried it with another NVidia Driver. The 535 for example? I know, you wrote, that the 540 works the best with Your Games in Wine. But maybe You could test it.

Using v535 fixes this issue for now

The monitors no longer flicker after triggering the screensaver multiple times.

Considering that some of my games crash and run poorly on v535, I'll return to v545 until Nvidia releases another driver for this issue.

Now that I know that it's a driver-related problem, I'd want to debug this issue further for a possible workaround on v545.

Thanks for helping so far ^^

1 Like