Mouse Cursor Disappears

Hi everyone. I would like to say that I'm really enjoying zorin OS but I have one small problem.

I installed the system on my main computer and everything works perfectly.

But when installing on my other computer there is a small bug when I go into system settings that the mouse cursor disappears.

My computer is a notebook and when I use the touchpad the cursor reappears.

I don't know if this is a common problem but I couldn't find a solution when viewing the forum

I'm new to the Linux world and would like to continue using Zorin OS. Hope everything is ok with this my first post and thanks in advance.

What sort of mouse is it?
Have you tried disconnecting then reconnecting the mouse whilst running ZorinOS.

Is the disappearing mouse pointer problem confined only to Zorin/Settings?
Is that on a light or dark theme background?

Can you give us the make and model of your notebook? (I refuse to use the term laptop as it engenders incorrect usage!)


It's a common mouse with usb wire I didn't try to reconnect it but it's a new mouse it was working perfectly on windows.

I'm using the dark theme and the problem appears exactly when I click on the Zorin system settings icon.

I don't know if this is relevant but I'm using an external monitor on the hdmi port. When using the notebook display the bug does not happen.



My notebook model is a Dell Inspiron 5557. The specifications are:
-Intel I7 6500U
-Geforce 930M
-250 GB SSD


Have you tried light theme to see if problem also occurs on that?

That may be significant, i.e. Nvidia graphics and HDMI output to external monitor. Maybe others that have this graphics combo can help you.

I tried to change to the light theme but unfortunately it didn't work.

Can you please clarify this? Changing to a light theme did not work? It would not use a light theme?
Or the graphics did not work?

Sorry about that, I managed to switch the system to the light theme but the problem continued. Cursor keeps disappearing when entering system settings.

1 Like

I am not sure if this setting really relates to your exact issue or not... But it is worth trying:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

I wouldn't think it was the Nvidia drivers unless you are enabling coolbits... but you may try testing against other drivers in Software & Updates > Additional Drivers

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.