Mouse Cursor Graphical Glitch

Hi all, I've been really enjoying Zorin OS 15.3 as my first ever Linux distribution but it hasn't been without its growing pains and issues. Thankfully most of them I've managed to solve but there's one issue I've come across and that's my mouse cursor is experiencing some fairly strong visual glitches.

In terms of control, it's perfectly fine after tweaking my touchpad settings. But whenever my cursor changes its shape depending on whether I'm hovering over a link or resizing a window manually or anything of that sort, I notice my mouse cursor glitching for a split second in a garbled mess with the shape of the cursor scrambling and jittering a bit before going into the shape it's meant to. I notice this almost every time and it actually makes me feel a bit sick to use Zorin for extended periods of time. I been trying to get a pic of this to show off what my mouse cursor is doing but the issue doesn't seem to show up in screenshots when I tried to capture it.

This issue also isn't unique to Zorin OS but even shows up in other distros of Linux I've tested out before and after installing Zorin. If it helps pinpoint the issue in case it's a driver or hardware related problem: my laptop is a refurbished Lenovo Thinkpad T430 with 8GB of RAM, an Ivy Bridge i5-3320M quad core with Intel HD 4000 integrated graphics. I'm not sure what my storage is but I know it's an SSD. I'm mainly using my laptop for lightweight work and of course Linux tinkering.

I've been trying to search for help and answers all over the internet but couldn't find any substantial answers and even looked into seeking help in Reddit communities and such but so few people commented and I wasn't getting anywhere fast. So I thought maybe it would be best to come here instead to see if anyone who actively uses Zorin knows my issues and can help point me in the right direction to getting this solved. Being a complete Linux noob in every way myself, any help would be hugely appreciated!

What you are describing sounds like an .xmc issue with the cursor theme.

I could be wrong... But it is easy to test.
You can test this by trying a Different X 11 Cursor theme.

If using Zorin Lite with XFCE:
Go to Settings > Mouse and Touchpad > Theme
Choose a different cursor from the list. Test it out.

If using Zorin Core etc. with Gnome:
Install gnome-tweaks if you have not already.
Open gnome tweaks by searching tweaks in your app menu.
Appearance > Keyboard and Mouse > Themes
(While you are looking at Gnome-Tweaks, you may also explore other settings and see if any of those relate).

If you have few to choose from for proper testing:

Here is a link to some wild ones...:stuck_out_tongue:
https://www.deviantart.com/grynays/gallery?catpath=%2F&sort=popularity

To Install:
Let's say you go with the one called "Vienna3Ubuntu"
Download the .zip file. Extract it in your Downloads with a Right Click.
In your Home folder (Hit ctrl+h if you need to) check if you have a .icons folder. If not, right click, select new folder and name it .icons
Place the extracted "Vienna3Ubuntu" folder in the .icons folder.

Then re-open your settings to choose the new cursor theme.

You could also try changing your refresh rate on your display. Desktops don't normally support 120hz or higher. It may be as simple as dropping to 75 or 60...60 is the norm. 120 is overkill for desktop rendering and may be your issue.

1 Like

I have tried that in the display settings but there doesn't seem to be any difference, even when I set it to another refresh rate and reboot the laptop just to make sure it will do the trick but sadly it doesn't seem to change at all.

Though there is something I have noticed and that's how the mouse cursor also seems to ghost when I move it around, like when I move the cursor around it leaves more cursor graphics behind, sometimes with the graphic cut in half. I can only see it for a split second but it's definitely happening so it could very well be display related. Sadly I have no clue where to start in getting something like that fixed :confused:

It seems to be an issue with the display settings since I've newly noticed the mouse cursor has some ghosting whenever I move it around around the screen. But unfortunately I've not made much headway on getting that fixed since changing refresh rate in the settings menu doesn't seem to make any difference for me :frowning:

However I did change the cursor from Breeze to Whiteglass and while it still hasn't fixed my issue as the graphical glitches are still happening, it has definitely made the issue a lot more bearable as there's a lot less scrambling of the graphics and jitteriness when changing shape. So at least until I can finally discover the crux of the issue, this should at least help me not feel sick :slight_smile:

Have you tried switching the USB port the mouse is plugged into?
I had a similar issue with keyboard lag and changing the port was the simple fix.

I've been almost entirely using the touchpad but even whether I plug in my wireless mouse or not, the graphics on my mouse cursor still go all screwey regardless unfortunately :confused:

I did find something saying this may be a vsync issue and might be due to screen tearing of some kind but I've got no clue how to enable that - would be worth a shot to see if that fixes my issue if you know how to get that working?

oohhh... You are not using mouse, you are using touchpad.

Please enter into terminal:

sudo rmmod i2c_hid sudo modprobe i2c_hid

If nothing, can you try:

sudo apt install xserver-xorg-input-synaptics-hwe-18.04

I actually have installed synaptics because originally I had massive issues with the touchpad and that fixed it in terms of controls. So it actually feels mostly great in terms of use but it really is just those nasty graphical glitches affecting the cursor that's causing me issues. But I'll give this a look at the very least :slight_smile:

1 Like

Had you tried this:

sudo rmmod i2c_hid sudo modprobe i2c_hid