Mouse cursor icons location

where are the cursor icons located in zorin? is .icon the right place or does/can zorin accept a specific path? I added few cursor icons in .icon, and in gnome tweaks I am seeing these cursor icons also for the icons. I think this is the normal behavior but can it be changes so that I see the cursor icons only in cursor drill down?

Yes, mouse pointer icon themes are placed either in ~/.icons or in /usr/share/icons.

This is a Really Good Question.
It never occurred to me to try to change it. This is set by XDG and I suspect that can be changed but having never tried, I do not know for sure or how to do it.

1 Like

maybe I did something wrong. I downloaded the cursors from, created the folder .icons in the home directory and pasted the extracted cursors in it. and in gnome tweaks in the icons drill down I see them too, beside cursors. it’s not a problem, I will not be spending much time there. but it bothered me a bit and thought maybe there was something that could be done about it or maybe I did something wrong during the process. also, there are few cursor themes that are not displayed in the list, don’t know why

Sometimes a theme creator /uploader will “double-wrap” the theme. This will cause them to not appear on the tweaks list.
The solution is to correct the Path by removing extraneous folders, in those cases. I cannot tell you if that is what you are experiencing without seeing more information.

But the solution if that is the case is to make sure that the path is ~/.icons/THEME-NAME/cursors/ACTUAL-FILES
where THEME-NAME and ACTUAL-FILES are the theme name and the files contained within the directory named “cursors”.
A double-wrapped theme may have the path (which is wrong):
Be sure that the ~/.icons/THEME-NAME also contains the files “cursor.theme” and “theme.index.”

If you like, you can link to the actual icon/pointer themes and I can look them over.

it’s this theme
I think it’s the case as you explain. but I don’t know how to fix it, and I am afraid to try because once I messed up the entire system playing around with themes

Hmm… I downloaded 02-Layan-cursors and extracted it into ~/.icons, then I opened my theme manager and it was there. I applied it and the mouse pointer changed over to the Layan.
Did I test a different file than you did?

the file is the same, at least the link is. i am trying to change it in tweaks->appearance

-shrug- gnome.

Any Gnomxperts?

I can ask on gnome subreddit if you tell me what to ask :wink:

I would link to the cursor theme as you did here. It shows up in Appearance settings on Cinnamon, Mate and XFCE. You can ask why it is not showing up as an option on Gnome Tweaks.

after not getting any help from reddit I tried on my own and just moved the content one level up (cut and paste). works now

1 Like

That’s… about what I said. But how did you get “one level down?” As the extracted file was set up, extracting it directly into the icons folder should have had it in the correct directory.

01-Layan was the parent folder and then came Layan. but Layan had to be the parent folder instead of 01-Layan. I compared the level until the index.theme and Layan had one extra level

Ah, ok. That link has several downloads. Without going and looking at each one, I can assume that you downloaded a different one than I had chosen. Because I tried two of them and they both were ‘directoried’ properly.

1 Like

yes, i compared with another cursor i did download which worked