Mouse gets stuck/frozen on Lenovo X270 Thinkpad

I currently installed Zorin 17.1 Pro on my X270 Thinkpad. An issue I am experiencing is that the mouse seems to freeze randomly. I could not see a common context yet when this would happen. The mouse would react again after touching the touchpad. It happens a bit to offen to ignore. The mouse is connected to an USB port. I could not find a solution yet in forum topics, maybe someone experienced similar issues and can help. Thank you!

Maybe try switching to X11 instead of Wayland?

1 Like

To clarify C141ZorinOS's response, when you select your username at login screen when it changes to password field, a small cog should appear bottom right of the screen. Click on it and change it to Zorin Desktop on xorg. Then enter your password to login. Keep us posted.

I already tried switching to X11.

I forgot to write that, sorry. I am trying different things for different issues since some days and forget to mention that I already did this step.

Thank you for clarification of this. This time I already knew about this. Always thankful for some details as not so much experience with this things.

I am currently trying to find out if there is a difference with X11 and Wayland. The mouse issue was not solved in X11 but maybe better than with Wayland.

I'll keep watching and looking for a solution :face_with_diagonal_mouth: :relieved:

Hmm these thinkpads,,
GDay @Julie , can you see if the thinkpad has "Hardware Accelerator" in the BIOS/UEFI please, if yes please disable it & try this for awhile.

1 Like

Gday @Ocka
I do not see Hardware Accelerator in the BIOS. In which part of the settings would this expected to be? Hm, probably the notebook might not have this.

Sorry i should have said, "Not all devices have hardware acceleration, it was just a hunch.
A few Browsers also have this option, if it was happening within the browser then the same hunch would be given. :slight_smile:

Keep up the good work.

I just saw "mouse acceleration" in mouse settings. Disabling it did not make it better. The issue was more bad yesterday, I don't know if because of disabling the setting or needing more ressources through different use of software/hardware yesterday. I also tried using a different mouse. Still with X11.

i have the feeling that there might be no solution or no quick solution for this issue... So yesterday I started to try to come to terms with it and to see a merit in it. I am trying to love it :roll_eyes: :relieved: . Has worked a few times!

G'Day @Julie ,
try looking through these links,
https://www.reddit.com/r/thinkpad/comments/rhbf8m/solution_thinkpad_short_freezes_on_gnulinux/

Hope this helps.

G'day @Ocka ,

thank you for sending the links!

I would like to try the instructions from the reddit link you gave.

https://www.reddit.com/r/thinkpad/comments/rhbf8m/solution_thinkpad_short_freezes_on_gnulinux/?rdt=36088

1. To resolve this issue, you must add this to the grub configuration ( sudo nano /etc/default/grub ) : GRUB_CMDLINE_LINUX_DEFAULT="i915.enable_psr=0"
2. Then remove old grub config : sudo rm /boot/grub/grub.cfg or maybe /boot/grub2/grub.cfg
3. After that generate new : sudo grub-mkconfig -o /boot/grub/grub.cfg or /boot/grub2/grub.cfg
4. Reboot your system.

**For better touchpad functionality add psmouse.synaptics_intertouch=1 to GRUB_CMDLINE_LINUX_DEFAULT."

I would like to ask something.

When using "sudo nano /etc/default/grub"
What I can see after using this, is this opening bootloader settings in Nano?

I don't understand how to use this interface and how/where to enter this lines. Could you tell me what I would need to do to add this to the grub configuration? GRUB_CMDLINE_LINUX_DEFAULT="i915.enable_psr=0"

I found Grub-Customizer and trying to find out how to use.

Thank you!

1 Like

G'day @Julie ,

Ok 1st (as it seems you have already done) ont he Grub config file, using the below command

sudo nano /etc/default/grub

In this window you can navigate via the "Arrow" on your keyboard.
Go to the line that has, GRUB_CMDLINE_LINUX_DEFAULT=
& add in between the " " marks, with a space from any other commands that maybe there.

Eg: In the Line by default you will see, GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
so it needs to look like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0"
it should look like this.

Then Click Ctrl+o to write the new entry.
The Enter to confirm/save it to the correct address.
Then Ctrl+x to Exit.

Normally we would get you to now run grub update by they seem to recommend a different way.

Lets try the known way

Open the terminal again & run the below commands,

sudo update-grub

then

reboot

Lets see if that works,,, take it for a spin & see if we have improvement.

@Ocka Thanks a lot for detailed instruction!

I have done like you described. I tested yesterday and there was no issue with the mouse the whole day. Thank you for support and showing right direction!

After following your instruction, would removing old grub configuration with sudo rm /boot/grub/grub.cfg still be necessary?

Adding psmouse.synaptics_intertouch=1 to GRUB_CMDLINE_LINUX_DEFAULT." Would it be this then?

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0 psmouse.synaptics_intertouch=1"

I was reading about Panel Self Refresh. Would it be safe to use this "temporary solution" long term?

"Panel Self Refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances FS#49628 FS#49371 FS#50605. A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0."* (from here Intel graphics - ArchWiki)

Thank you.

1 Like

No you do not need to run the other instructions.
We have done the same, just in a quicker way.

When you added to that default file, when we updated the grub & rebooted,what is, is changes a file called .cfg (A configuration file my have many commands, what we added when saved will be read by the .cfg file & follow the instructions within the file. we had made the changes to that file via (update-grub command).
The long way to do this is via the (rm "removal" of the file & mk " "make", a new file.)

Glad to see it's working .Enjoy Zorin OS.
Regards.

P.s. i moved the "Solution" to the post that explains it a little better.

No i wouldn't add anything more like "psmouse.synaptics_intertouch=1", if it's working don't fix it :slight_smile:

Thanks again! Grateful for those explanations.
Regards

1 Like