Mouse-pointer disaapears randomly / old iMac


i would love to switch from Ubuntu to Zorin. I am currently running Ubuntu on an old iMac (2010 with a Radeon 4670) without any issues.

What keeps me currently at Ubuntu is strange behavior of the mouse-pointer. It gets invisible randomly. The system does not freeze, the pointer just gets invisible. I can open and close apps. Only a reboot brings the pointer back. Tried the core-Version 16.3 and 17 beta. Same effect. Pointer disappears randomly. Sometimes after 5 Minutes, next try it happens after 4 hours.

already found and tried this:

gsettings set org.gnome.settings-daemon.plugins.cursor active false

no difference.

Any Ideas welcome ...

best reagards

Have you tried this suggested solution?:
amd graphics - Ubuntu 20.10 on mac: Mouse cursor disappears randomly - Ask Ubuntu.

I believe that this is due to a specificity in the Mac hardware.
Some of the users in that thread comment that it did not work for them or had other issues, however, elsewhere on the web, users post that it worked perfectly. I believe it is worth trying.

You also need to reboot after this and run

sudo apt update && sudo apt full-upgrade


@Aravisian looks like that fixed it. At least for tonight... hope it stays like this :smiley:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.