Mouse stops interacting between windows and taskbar


I have tested out Zorin on a older laptop at home (pro version) for some months, and have worked well. Really liking the sleek UI, and want to get fully comfy with it.

Here the other day I decided to try to give it a go on my recently replaced work computer, which is a Lenovo Yoga 920 from 2017 16mb ram and touch screen. I've so much love for that computer, and although old, I think it should be decent enough to perform quite well (if disregarding windows!).

But after testing for a workday today, on three occasions I have had problems that it seems to stop responding to mouse commands in anything else than active app. I can alt-tab to switch, then mouse works in that app.

I have only been able to fix the problem with ctrl-alt-del -> logout -> login.

Any tips to how to troubleshoot? A bit new on Linux (have only been using Xigmanas, Truenas and RPIs at home)

Any help appreciated!

Do you have xserver-xorg-input-all installed?
It can be installed with

sudo apt install xserver-xorg-input-all

Thanks for attempting to help, Aravisian :slight_smile:

Yeah, that seems to be installed (when running the command).

I located this thread without seemingly a resolution. Resembles my experience from what I can see.

Have you yet run

sudo apt update && sudo apt upgrade

in your terminal?

Does the mouse retain interaction within the open window, but cannot act outside of that window?

It upgraded the following:

The following packages will be upgraded:
  libc-bin libc-dev-bin libc6 libc6:i386 libc6-dbg libc6-dev locales

Yes, I was able to use it within current active window (though I remember it as rather buggy... Ie., I noticed in Edit: Chrome (not Firefox) on Azure DevOps that expand and collapsing list items needed to double click suddenly, and drag and drop list items did not work.

Which kernel are you running on?

uname -r

Is the touchscreen functionality enabled or disabled - or have you been using it?


Touchscreen enabled, but was not actively using it when it happened. Where connected with a usb-c hub, two extra monitors and a logitech setpoint with keyboard and mouse.

These are a lot of factors...
I would try simplifying the set up to see if the cause of the mouse glitch can be narrowed down.

It seems possible that the touchscreen may conflict with the mouse. I would begin by disabling the touchscreen and testing.
I would definitely try testing this without Logitech Setpoint, as well.

1 Like

Yep, agree. Will do that and report back.

Thanks a bunch so far!

I'll search a bit to find a way to disable touch :slight_smile:

To Disable:
You might try

sudo modprobe -r hid_multitouch

To enable:

sudo modprobe hid_multitouch

Hmm, that command ended up with hiding the mouse cursor until I rebooted. Touch worked before and after reboot :upside_down_face:

No option to disable in bios unfortunately.

Tested a bit on the options listed here, but should I expect any current data in rc.conf (its empty/non-existing)?

Tried as follows, but does not seem to list as usb device.

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0cf3:e300 Qualcomm Atheros Communications
Bus 001 Device 003: ID 06cb:0081 Synaptics, Inc.
Bus 001 Device 002: ID 04f2:b5da Chicony Electronics Co., Ltd EasyCamera
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


xinput list

1 Like

Got this, but a bit unsure where to go from here (really appreciate your patience!)

xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Wacom HID 5113 Pen stylus id=10 [slave pointer (2)]
⎜ ↳ Wacom HID 5113 Finger touch id=11 [slave pointer (2)]
⎜ ↳ SYNA2B31:00 06CB:7F8B Mouse id=12 [slave pointer (2)]
⎜ ↳ SYNA2B31:00 06CB:7F8B Touchpad id=13 [slave pointer (2)]
⎜ ↳ Wacom HID 5113 Pen eraser id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ EasyCamera: EasyCamera id=9 [slave keyboard (3)]
↳ Ideapad extra buttons id=14 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]

Ah, this seemed to work:

xinput disable 11

1 Like

Awesome, thanks again, I'll do some more testing then!

Where using my computer with touchscreen disabled yesterday evening. Never got any issues.

Tested today to only connect Logitech Setpoint (keyboard and mouse). Things started acting rather weird not long after. So seems like its something related to that. Im pretty sure its the same issue reported in the mentioned unresolved thread.

I will try to isolate testing to mouse, then keyboard. But if anyone have recommendations to things to check, all suggestions would be highly appreciated :slight_smile:

1 Like

Im pretty sure there my Logitech MX Master mouse is the problem.

I've been able to reproduce an annoying problem I have had on my Windows machine whenever docking, similar to the issue with Zorin. Whenever mouse connects to the computer, Im not able to switch windows with mouse. Though, on windows, ctrl-alt-del followed by esc fixes the problem easily.

The saga continuous...

Mouse was the problem. It does not want to reset nor take firmware updates, so I replaced it. Problem solved on Windows at least. Will test on Zorin as well, but pretty sure its related.

Wow, great detective work and methodical testing.
For such a strange problem, troubleshooting those symptoms really had to be.