Moving video files to a USB Hard Drive

I have been using the GPU screen recorder, and it works great as long as I leave the files in videos. But, I must move them because my hard drive on the pc is only 270 Gigs, so I move them to my 2 terabyte external HD. For most videos this works great but today I tried moving the latest video and when I tried to play it from the ext HD I got the error "file is empty". However, when I right-click and look at properties, I see that it is not empty but has 1.8 Gigs in it. I also tried playing it with VLC media player with no luck. Then I tried recording it directly to the ext HD but that did not work and I got the same error. Has anyone else run across this? Any ideas? Thanks for any help I can get.

I don't know what it could be, maybe a permission problem? Try run

ls -l <path>/<file>

Im not so good with the terminal but when I tried I got this error: dave@dave-Aspire-E5-575G:~$ ls -l /
bash: syntax error near unexpected token `newline'

You need to give the command a path and filename eg. ls -l /home/storm/Documents/test.svg

You can drag the file into the terminal after the ls -l command if it's better for you.

1 Like

Also have you tried replug the external HDD?

Also remember to unmount your external drive when not in use or you could potentially fall foul of a ransomeware attack. Always connect external drive power to wall socket/extension socket and power on at socket or if power switch on external drive turn that on before connecting to USB. To power off Use Disks, select the drive and select power button on Disks interface to power down.

Well, I tried again, only this time I used the "copy to" function, so I would not lose my video to the move. Still, when the video file got there, the error claims that it is empty even though the properties say 1.9 Gigs in the file. This time I also plugged the Ext HD directly into the USB port, as I had been using a USB extender with three ports. That did not seems to matter, but at least this way I didn't lose my video file. It is just really odd that I can get small music files to copy but not movies.

Another thing I thought about is re-installing Core to see if anything changes. I also have Zorin Lite and Linux Cinnamon/Mate installers on USB. What do you think about that?

What file system is the External Hard drive formatted to? There may be specific file troubles with larger files if the format is not compatible.

Is the external hard drive powered solely by the USB Cable? Mine can be powered by USB, but also has a power port with a plug that goes to the wall outlet. If I use the External Hard Drive lightly, the USB supplied power is sufficient. But with heavy use, I must plug it into the wall outlet. Otherwise, the power to the drive is insufficient under a heavy load and it can develop read/write errors when the drive cannot spin at the proper speed during write.

You should also test the hard drives integrity for bad sectors and blocks. If it is NTFS format with bad sectors and fragmentation, that may make writing large files difficult. Or if the drive is very full.

Not sure if I can answer all these questions adequately so I will report what I see when I open it up. SDK PSSD SSD 3.0 2.00. Size 2.1 TB Master Boot Record Ser # 8860621091334422748. Device /davsdb1 UUID 76EB-CACF Partitution type NTFS/exxFAT/HPFS Bootable Contents exFAT version 1.0 mounted at /media/dave/wd
The drive is solely powered by the USB. No ext power.
Not versed in how to test or defrag the drive. I am familiar doing that on Windows though.
The power thing would explain why I was able to move small music files and not large movie files.
That's about all I know. What you said gave me an idea though. It is late here now but tomorrow I will record a movies and break it down into two maybe even three parts to see if that helps. Like I said the App did record some movies and others it would not so it might just depend on the size. I will let you know. Thanks.

1 Like

Bad news. I downloaded the movies in 30 minute sections. Those played fine in videos, but the minute I copied them to the USB hard drive they corrupted and would not play. So, back to square one. I also tried downloading in 15 minute parts and that worked for all but two segments. However, a two hour movie would require like 10 downloads or so.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.