Mozilla Firefox menu item accidentally deleted! (Zorin OS 17 Core)

While poking around the Main Menu (editor), I accidentally Deleted the link to Mozilla Firefox (I wanted to click the Properties button).

From the Terminal, I typed: flatpak run org.mozilla.firefox - and it ran.

I then:

  • Restarted the computer. No change (as expected).
  • Uninstalled Firefox via Software, and restarted the computer.
  • Re-installed Firefox via Software, and restarted the computer.

After all that, there is still no Mozilla Firefox icon in the Zorin menu.

I can start it via Terminal, do I get the icon back?

When I press the Meta key and type Firefox, here is what I see:

Yet, according to Software:

And according to the Terminal:

Any assistance here would be appreciated. It surely cannot be this complicated to get an icon back?

I tried to add a launcher manually:


...but nothing happens when I click OK - the window sites there. I verified that that /usr/bin/flatpak exists, and running that command in a Terminal works (Firefox opens).

Hello all,
I was able to resolve the problem after some troubleshooting.

When trying:
sudo apt update && sudo apt upgrade

Got an error: jammy Release
404 Not Found
Reading package lists... Done
E: The repository ' jammy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

I headed over to Software Updater, where I could click "Settings > Other Software" and deselect the offending repo.

I then closed all, and:

  • Open a Terminal and run: flatpak remove org.mozilla.firefox.
  • Rebooted the computer.
  • Opened a Terminal and run: sudo apt update && sudo apt upgrade.
  • Opened Software and re-installed Firefox.
  • Rebooted the computer.

Firefox icon is back!

Strange. That's what I get for trying to get my "Shenzhen Goodix Technology Fingerprint Reader" working! :slight_smile:

I prefer not to use flatpak, my preference is APT and if no APT, I will download directly. My preference is for Firefox ESR (Extended Service Release) and as I have long-pushed that this should be the default Firefox, in particular for Corporate, and more importantly, Education establishments as only the ESR version can be 'locked down'.

Vimeo 4 minutes 10 seconds in (I tried using the link at the set time in another thread, but it does not work.

1 Like

Thanks, @swarfendor437 - after posting my last update...the firefox icon doesn't work!

I downloaded a version of Firefox from Mozilla directly, but didn't install it yet (it is sitting in my Downloads folder).

Just to get going, I had to download the Snap version (which works, if a bit slower to start).

Will troubleshoot this more in January, as time permits! (will definitely check out your Vimeo link).

Thanks again! :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.