MP3 software Tagger, unable to save changes. Please help!

Dear Community,

I have new MP3 music and I wanted to edit the Music Tags. I go in the software store, install Tagger, which seems to be excellent. I can open files, perform the edits, but cannot save. I get an error message.

Specs: Zorin OS Pro, 16.3.
Software: Tagger, Nickvision, 2023.9.1.

What I did:

  1. I believed that it was a file permission thing. I chmod +777 the music file and the target folder.
  2. With previous learnings with Thunderbird, I opened FlatSeal and give all permissions to the files.


Nothing is working.

What am I doing wrong? Why is this complicated?

Thank you.

What does the error specifically say?

Is Tagger a flatpak or were you assuming it may be?

Aravisian, i don't really know. I just install the program from the software store, assuming compatability.

It might be. I can see it in FlatSeal, therefore i conclude it is Flatpak.

The error just says cannot save file. Nothing more.

You can check with

flatpak list

...or using the Sources button in the Software Store

...or by scrolling to the bottom of the install page for the app in Software to read the sources.

Hi Aravisian,

it is a flatpak:

Thank you if you can help.

I know that feeling.

Have gotten those moments on every O.S. I have ever used including WIndows, GnuLinux, MacOS and a few most people don't know even exist.

What error did you get?

Hi, the error is cannot save file. Just that. I can open, edit, but cannot save. Seems to be a writing permission. However, the file and filder has a chmod 777.


Have you tried MusicBrainz Picard? Had some similar issues using Tagger - Picard was able to save the changes I needed to make. I hate having issues with tags... I feel your pain though.

There are also EasyTag if Tagger won't save.

1 Like

If it's a flatpak it should contain all dependencies.

1 Like

Dear community,

Thank you PlumpKibbles for the solution. I tried Tagger, Easy tag, Ear Tag and MusicBrainz Picard.

The first 3, they simply do not work for various reasons. They were installed via the Software center, nothing fancy. Cannot save files, or corrupts files, do not play in VLC, etc.

MusicBrainzPicard works, but I hate the software. Very complicated for nothing.

I must admit that I'm becoming fluttered with Linux incompatibilities. I am wondering, is this a Zorin OS thing? Or just Linux in general.

I will continue with Zorin for a while, perhaps I will learn and become proficient. I Must admit for anybody that is looking for simplicity, this is not working.

1 Like

I tried something else, and it works. Rhythmbox that seems to be pre-installed.

Another solution for struggling newbies.

1 Like

Awesome!! Glad I was able to help :smile:

Did have to learn how to use Picard myself .. Gets kinda complicated, really fast - I thought. For what I needed to do though, spot on! And tons of guides out on the web to help, too :grin:

Don't think 'incompatible' - rather, alternative.. There are tons of applications that mimic or even straight-out perform the same actions as Windows apps! On the software side of things.. On the hardware side, yes - there can be some incompatibility issues with very specific, proprietary hardware. The whole 'Windows Vista' signed hardware pops into mind :person_facepalming:.. BUT - unless it's something like, straight off the soldering bay - it's likely to be compatible, hardware wise.

I'm on another Linux machine right now but, did you install the optional additional packages like zorinos-restricted-addons | zorinos-restricted-extras? Also, there are additional plugins through the Software Center for codecs and such. For USB stuff, I would install libusb-dev as well. For videos, since I got the codecs, I just use the Videos app to play .mpg through .mp4 - haven't tried an .mkv - no issues so far.


Hi PlumpKibbles,

yes, I had those installed, I seem to be up to date. I think that this is solved, finally. Seems that each little thing becomes complicated.

I really appreciate the community and people like you.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.