MS Edge is having display issues on Zorin OS

OS: Zorin OS 16.2

I installed zorin os and first i faced the bluetooth issue but fixed by reinstalling some drivers and restarting.
Now i installed edge from flatpak and when i selected some text and right click on it a display issue on that area came . I fixed by disabling smart menu and using regular right click view. But i faced the issue again with topbar of the browser.

Can someone tell me what's the issue ?

You can checkout the top right , see the display issue there.

Flatpak and Snap are both double sandboxed.

You can try using flatseal

sudo apt install flatseal

to assign system permissions to your flatpak Edge.

You can install a .deb package of MS Edge that respects and interacts with your system (and remove the Flatpak version):

I'm using MS edge ( i tried the stable , beta, dev) in Zorin, it's perfect, but i haven't tried ms edge from snap or flatpack, i recommend to install it from the official site of Microsoft:

Thnx @Aravisian @eid @Mr_Magoo , was using flatpak for better package management and updates , but nvm.

also @Aravisian sudo apt install flatseal didn't work

mini@mini:~$ sudo apt install flatseal
[sudo] password for mini:     
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package flatseal

But it's on flathub, Flathub—An app store and build service for Linux

( don't know if i should install this since it's flatpak)

flatpak install flathub com.github.tchx84.Flatseal

Hm will try it for now deb is working fine :). I wasn't sure if a flatpak sandboxing issue will be fixed by another flatpak app, but nvm will give it a try too.

Anyways thanks to all!

hey. I've been using MS Edge Ubuntu deb on Zorin for more than 1 year with the Beta releases, never had a single problem. Crazy stable for an MS app :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.