Mt7601 chipset wifi adapter not find in zorin os

I have a wifi adapter with mt7601 chipset.
My operating system is zorin os version 16. Kernel version is 5.15.0.
In my desktop, previously i used ethernet cat-6 cable and it's works perfectly work.
Now i buy a new wifi adapter .When i plug in my wifi adapter with my pc i can not find anything any error or anything else.
When i connect this wifi adapter with windows 10 then it's perfectly work..
How can i solve this issue??
here is the some information when i tried many solution from google and youtube :




I love the shell in your terminal.

You are showing mt7681u, what is the model /Device that you are using?


This device i bought yesterday

If you are not dual booting Windows, please ensure that in your BIOS / EFI settings, secure boot is disabled.
It must be disabled, so if you are dual booting Windows and wish to use Secure Boot, please say so.

Once Secure Boot is disabled, please run the following in terminal in order to install the needed drivers (If you have not already done so.)
Get necessary packages if needed:

sudo apt install git dkms

Get the driver package:

git clone https://github.com/jeremyb31/mt7601u-5.4.git

sudo dkms add ./mt7601u-5.4

sudo dkms install mt7601u/1.0

Hopefully, using DKMS, this will connect the module to your current kernel.

1 Like

here is the output

So you have already installed those drivers, it seems.
Have you tried using modprobe to ensure that the prober sees them?

sudo modprobe mt7601u

1 Like

See if the solution with 7 votes helps here:

It would also help if you would install net-tools via terminal, then run

sudo ifconfig -a

and post back the results.

1 Like