MT7922 bluetooth not work

I have tried many ways for my MT 7922, but the result is still not able to enable Bluetooth normally, and the WIFI is working normally.I tried to upgrade the kernel, but it still didn't work.

robot@Yilong:~$ lshw -c network
WARNING: you should run this program as super-user.
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: enp2s0
version: 15
serial: b0:25:aa:66:83:d9
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=6.8.6-060806-generic duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=10.0.0.18 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:53 ioport:f000(size=256) memory:fcd04000-fcd04fff memory:fcd00000-fcd03fff
*-network
description: Wireless interface
product: MEDIATEK Corp.
vendor: MEDIATEK Corp.
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlp3s0
version: 00
serial: 1c:ce:51:39:d7:3e
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=mt7921e driverversion=6.8.6-060806-generic firmware=____000000-20240409163347 latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: iomemory:7f0-7ef irq:96 memory:7ff0a00000-7ff0afffff memory:fcc00000-fcc07fff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

robot@Yilong:~$ sudo dmesg | grep -i bluetooth
[ 6.254966] Bluetooth: Core ver 2.22
[ 6.254993] NET: Registered PF_BLUETOOTH protocol family
[ 6.254994] Bluetooth: HCI device and connection manager initialized
[ 6.254999] Bluetooth: HCI socket layer initialized
[ 6.255001] Bluetooth: L2CAP socket layer initialized
[ 6.255006] Bluetooth: SCO socket layer initialized
[ 6.470459] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 6.470464] Bluetooth: BNEP filters: protocol multicast
[ 6.470469] Bluetooth: BNEP socket layer initialized
[ 8.358338] Bluetooth: hci0: Opcode 0x0c03 failed: -110

Assuming first that your BIOS is up-to-date and you have Fast Boot and Secure Boot disabled in BIOS. Also if Windows was/is installed, that Fast Startup is disabled.
Try complete power down of the machine as suggested in this post here: MediaTek MT7922 Bluetooth not recognized - #14 by lemone - Kernel, boot, graphics & hardware - EndeavourOS

All your advice I have tried ,but it did't work unfortunately!