Multiple instances of a drive in file manager media list

Zorin has worked as very well and as expected for a month or two (since I installed it), but then I'd mount my 'G' drive to back up some stuff and I am now seeing G Drive, G Drive1, G Drive2, etc. I'm now also seeing other drives that are no longer mounted still being displayed with a digit after their name. What's going on and how can I correct it? (I can boot into my Mint distro and everything is normal, so I'm suspecting something in my Zorin setup.)

Is "'G' drive" something from Google or is it an external Harddisk from 'G'? How did you mount it, entry in your /etc/fstab, mouseclick in your filemanager or with an extra software?

Can you open Disks in your computer and send a screenshot of how the drive shows up there?

Internal drives all appear normal. The dupes are all external USB drives that are mounted through file managers/media menu click. /etc/fstab hasn't been touched by these hands, I'm still NEW at Linux after driving M$oft for 40 years...

Disks appears normal

Kruusader (and others) show unmounted drives with the number at the end

What is the output of lsblk when you run that in a terminal?

john@Linux-Win-PC:~$ lsblk
loop0 7:0 0 4K 1 loop /snap/bare/5
loop1 7:1 0 165.7M 1 loop /snap/brave/381
loop2 7:2 0 166.6M 1 loop /snap/brave/383
loop3 7:3 0 105.4M 1 loop /snap/core/16574
loop4 7:4 0 104M 1 loop /snap/core/16928
loop5 7:5 0 55.7M 1 loop /snap/core18/2812
loop6 7:6 0 63.9M 1 loop /snap/core20/2182
loop7 7:7 0 74.1M 1 loop /snap/core22/1033
loop8 7:8 0 74.2M 1 loop /snap/core22/1122
loop9 7:9 0 14.7M 1 loop /snap/crazy-chicken-pinball/1
loop10 7:10 0 66.5M 1 loop /snap/cups/1024
loop11 7:11 0 268.3M 1 loop /snap/firefox/3972
loop12 7:12 0 268.2M 1 loop /snap/firefox/4033
loop13 7:13 0 164.8M 1 loop /snap/gnome-3-28-1804/198
loop14 7:14 0 349.7M 1 loop /snap/gnome-3-38-2004/143
loop15 7:15 0 497M 1 loop /snap/gnome-42-2204/141
loop16 7:16 0 504.2M 1 loop /snap/gnome-42-2204/172
loop17 7:17 0 91.7M 1 loop /snap/gtk-common-themes/1535
loop18 7:18 0 263.9M 1 loop /snap/kate/171
loop19 7:19 0 16.8M 1 loop /snap/kbackup/22
loop20 7:20 0 198M 1 loop /snap/kdf/98
loop21 7:21 0 438.3M 1 loop /snap/kf5-5-110-qt-5-15-11-core22/3
loop22 7:22 0 443.2M 1 loop /snap/kf5-5-111-qt-5-15-11-core22/7
loop23 7:23 0 192.4M 1 loop /snap/konqueror/35
loop24 7:24 0 199.1M 1 loop /snap/kshisen/96
loop25 7:25 0 55.3M 1 loop /snap/mesa-core20/151
loop26 7:26 0 313.8M 1 loop /snap/regardsviewer/106
loop27 7:27 0 314M 1 loop /snap/regardsviewer/107
loop28 7:28 0 99.5M 1 loop /snap/smart-file-renamer/53
loop29 7:29 0 40.4M 1 loop /snap/snapd/20671
loop30 7:30 0 39.1M 1 loop /snap/snapd/21184
loop31 7:31 0 303.1M 1 loop /snap/wine-platform-5-stable/18
loop32 7:32 0 347.1M 1 loop /snap/wine-platform-runtime/364
loop33 7:33 0 347M 1 loop /snap/wine-platform-runtime/365
sda 8:0 0 2.7T 0 disk
└─sda1 8:1 0 2.7T 0 part /media/john/D Drive
sdb 8:16 0 5.5T 0 disk
└─sdb1 8:17 0 5.5T 0 part
sdc 8:32 0 7.3T 0 disk
└─sdc1 8:33 0 7.3T 0 part /media/john/F Drive
sdd 8:48 0 4.5T 0 disk
├─sdd1 8:49 0 200M 0 part
└─sdd2 8:50 0 4.5T 0 part /media/john/X01 Names
sde 8:64 0 7.3T 0 disk
└─sde1 8:65 0 7.3T 0 part /media/john/G Drive3
sdf 8:80 0 5.5T 0 disk
├─sdf1 8:81 0 200M 0 part
└─sdf2 8:82 0 5.5T 0 part /media/john/Sea-6t-01
sdg 8:96 0 4.5T 0 disk
└─sdg1 8:97 0 4.5T 0 part /run/timeshift/backup
/media/john/Zorin Timeshft
sdh 8:112 0 3.6T 0 disk
├─sdh1 8:113 0 200M 0 part
└─sdh2 8:114 0 3.6T 0 part /media/john/S-09-4t
nvme0n1 259:0 0 1.8T 0 disk
├─nvme0n1p1 259:1 0 100M 0 part /boot/efi
├─nvme0n1p2 259:2 0 16M 0 part
├─nvme0n1p3 259:3 0 462.4G 0 part
├─nvme0n1p4 259:4 0 509M 0 part
├─nvme0n1p5 259:5 0 455.6G 0 part
└─nvme0n1p6 259:6 0 944.4G 0 part /var/snap/firefox/common/host-hunspell

Currently System has 4 USB drives attached, one is called G drive, then S-09, Timeshift and Sea-6t-01. Native are D, E, and F. X-01 is not attached at this time.

A few more questions:

Do these additional folders take you to the same drive location, i.e.: are they duplicates? Also, when you unplug this drive, do they remain in the file system? If they do, can you still access them or do you get an error? And, if you plug the drive back in, is there a new folder created with an increased number i.e.: G Drive 4, 5, 6...?

How about @Pati's question: did you specify any drives to be mounted automatically in your /etc/fstab file?

From what I gather from other questions I found online, this could be due to a bug on the kernel. Zorin OS usually upgrades the kernel to be a on a higher version than the one found in the Ubuntu base, but I don't know if they are doing any customization on top of it.

I can't be sure this is the case, I'm just speculating, but there was another thread with a similar issue reported.
There, I suggested to format the drive as I initially thought it would be either a corrupted file system. The OP hasn't confirmed whether this helped or not, but even if it did the root cause may have been on how Zorin OS recognizes drives.

Unplug it and 0 goes away, the rest remain.
At first I just had Drive G, then 0 showed up, then I noticed 2 and then 3!!!
On the Krusader screengrab, L-06-5t1 is not plugged as, nor is X-03-5t1. They just show up...

All file access is through Krusader, Dolphin, XFE, or File Manager PCManFM, I don't play in terminal unless it's specifically directed by someone.
The drive at SDE1 is actually named 'G Drive'.
Access G Drive gives Error: Cannot open the folder /media/john/G Drive
Access G Drive1 gives Error: Cannot open the folder /media/john/G Drive1
Access G Drive2 gives Error: Cannot open the folder /media/john/G Drive2
Access G Drive3 now works as expected.

I don't know when 4 will decide to show up...

L-06-5t is not plugged in but still shows L-06-5t1 available, however trying to
Access Drive L-06-5t1 gives Error: Cannot open the folder /media/john/L-06-5t1

A thought...
Is there a way to just refresh the kernal? OR... reinstall 17 again and let it update everything and then use timeshift? I hate to imagine the time sink that can possibly become...

...and I think I mentioned I have Mint on another partition and it works as expected, that's why I'm thinking 'something' got corrupted in a Zorin file somewhere, I just wouldn't know where to look or what to look for. (Can Timeshift have grabbed a copy from before everything went crazy???)

...AND it's STILL not reason enough to reconsider M$oft, at all...
Thanks for your help and time on this, it's frustrating. (but I'm learning as I plod along!)

That is certainly an option... a fresh start (a.k.a: turning it off and back on again™) tends to work well quite often actually :smiley:

If you are willing to put in the time I wouldn't be opposed to doing this. Making regular snapshots of your system using Timeshift is also a good idea nonetheless.
But since we still don't know for sure what is causing this there's no way to guarantee it won't happen again so bear that in mind.

Before going for that option, have you tried to unplug all drives and delete any duplicate folders that remain?
Normally, the folders that you find in /media/john are dynamically created and deleted as you plug/unplug external drives. It's possible that something caused this process to fail and keeps prompting the system to create new folders without deleting the existing ones every time. Deleting everything here may just be all it takes. Not what I would call a good solution but it's quick and safe to test. Just make sure you are deleting only empty folders that don't lead anywhere.

Worth a shot, I'll try that in the morning. None of my sata drives are showing a problem, just the USB's, so it's a simple test.

Unable to delete. Permission Denied...
...but... they ONLY show on file managers driven from the desktop programs. (Krusader, Dolphin, XFE, or File Manager PCManFM or Double Commander). Disks and GParted access the drives differently and they have no issues. Maybe see if terminal can access them and see if it IS the desktop wrapper that's corrupt? Too much I don't know about how Zorin does it's magic within the walls of Linux...

It makes sense that Disks doesn't show any errors as it doesn't try to access the contents of the drives, it only reads information about them.

These folders are probably owned by the root user. You can check this quickly by running this on the terminal:

ls -l /media/john

and to overcome this, launch your file manager of choice with: sudo -i nautilus; change "nautilus" with "krusader" or whatever other file manager you prefer. What this will do is launch as if you were the root user (don't get too used to doing this, it's better to use your normal account for every day tasks).

Try again and see what happens, just be careful not to delete anything important :+1:

Well, it all became moot as I lost access to Zorin, Mint and my Win partitions after a power bump last night. My iPad is still working so I can still do some stuff. Now trying to rebuild and see what I can recover. Just now realized Timeshift doesn’t do as much of a backup as I’d hoped, so moving forward from there, it’s rebuild time, again… A lot was saved on alternate drives (that seem to have escaped the destruction), but time will tell what’s gone. Thanks again for the assist and I’ll let you know if I find anything notable.

Ouch... Yeah, I don't think Timeshift can help much in this case. I like to think about it like this: snapshots are all about system state; backups are all about the data.

Data, you can share with others and is usable right away wherever it goes. For example, sending a picture or video file. Snapshots cannot be shared across systems, as they are specific instructions on how to re-construct a particular set of files based on a previous known state.

In any case, good luck with the rebuild. I hope nothing was damaged. Maybe this is the perfect excuse to do a little clean up? :smiley:

Cleanup INDEED! I'm back to my dual-default, Mint and Zorin. Win is gone, I haven't opened it since September when I got hit with the ransomware lock-up and haven't missed it as much as I'd imagined. Of course, next to me is a 2015 iMac that is an excellent alternative, but is stubborn in so many other ways, and the iPad is an absolute lifesaver.
I'll be around and looking in, hopefully no more drive games! Thank you again for the assist and lifeline, I guess some Linux training is in order to understand the under-the-hood mechanisms at play here. This isn't DOS anymore, Toto... :grinning:

1 Like

The first time I tried MacOS... I hated it, despite all the praise it gets for its outstanding UI/UX design. When something is new there's always some learning curve involved. Just keep at it!

1 Like

Well, after a bit of head-pounding and poking about, I found, to my horror after getting Mint working like I want, I ended up with a D Drive AND a D Drive1 (on Mint this time)! Ok challenge accepted!!! What I suspect is somehow there was a 'ghost' of the drive left behind when the program closes (in this case, it was Krusader) and when Krusader was reopened, it already had a D Drive present so, I assume, it just added the 1 to the end and sallied forth. I found Dolphin and xfe managers would see the 1 after it showed in Krusader (they must be sharing 'SOMETHING', right?) but Files didn't see the 1. I then disabled the D drive in my Bios, brought up Mint, and Krusader was still showing a D Drive available! I couldn't delete it through Krusader BUT Dolphin would allow me to enter the password and delete the D Drive entry. Re-enabled D through Bios and everything was good to go!

I hope I'm the only lucky schlep that has run into this problem, but just in case you hear of it again, look me up!

Be well sir (or ma'am), and again thanks!


1 Like