Multiple Monitors - One Workspace - Programs Always Open on Built-In Monitor

This may be an Ubuntu thing as well but my Google searches for my issues have turned nothing up, hence the post.

My issue:

  • Applications like System Monitor and Settings and others not remembering to open on Primary Monitor's desktop. Even after moving over to appropriate desktop, closing and re-opening.

My questions:

  • I want to know how to enable an application to open on the same connected monitor's desktop, no matter what.
  • I also want to know if it is possible to have an application similarly remember its position; either based on last closed position, or modifier-key exit, etc...

EDIT: To follow-on to original post, minimized applications also ALWAYS animate to the wrong 'Primary Monitor' that I set in 'Settings'. If using the image below for reference for instance, all the open windows on Display 2, will minimize to Display 1 - and when clicking on them to restore, I see the animation start all the way over on Display 1, finishing on Display 2. This seems wrong.

I have also used the Tweaks tool and have ensured that 'Static Workspaces' is enabled and set to '1'. I also set my 'Workspaces are set to span displays' option without success.

Thank you for any assistance. Looking for any advice.
Please refer to the image below for an idea of what I am talking about.

There are a couple of things you may try:
Settings > Displays > Drag displays to match physical set-up

You may try using Gnome Tweaks > Workspaces > Display handling and select 'Workspaces span displays'. Once done, drag an Open Application window onto the monitor you want it to open on. Close that window, then try reopening it and see that it opens on the same monitor it was closed on. Repeat for affected applications.

Finally; Devilspie. I have never used this window matching utility so can offer little help on its configuration or usage:

But it may be able to help you solve the problem.

So I'm not leaving you hanging, thank you for the suggestions. When I get some extra time I will get into it and get back with the results so as not to leave everyone else hanging.

I think - and I'm not 100% sure here - that the most recent update ("Flash Icons"?) broke the Settings/Display application screen. I no longer have the options I remember seeing for "Mirror", "Extend Display", etc. You know, those buttons at the top?

The only reason I noticed this is because one of my displays was set to mirror another, while the built-in display remained normal. Since day one, I've had the same setup for three separate, non-mirrored desktops.

Am I going crazy? Where are those located?

\\\///\\\///
For the testing of the suggestions you gave:

I already had it set to that since day one.

I can't tell if it worked for the ones I previously moved and dragged, but I can say that it doesn't work for the Tweaks application. I have been able to somehow get Chrome and one, maybe two?, applications to open on the primary screen I prefer. It's not a massive issue I just open an application up sometimes and get confused wondering where it is - I have multiple monitors spread.

I was hoping to avoid third-party download or set up, but I will try it. Those kinds of tools can be fun anyway - I think?

Thanks, and no rush when you get to this.

Probably not crazy.
Check your current kernel:

uname -r

What Graphics Card do you have? It may be the latest kernel update caused your graphics display to not work properly.
You can test this by rolling back to the 5.11.0-46 kernel. Or the 5.11.0-40...

Sorry for the late reply. Been busy.

As for the kernel question: I am on kernel 5.13.0-28-generic
For rolling back to any other, that is something I do not have the expertise, or time to research at the moment.

To be frank I haven't had much time to test much of the issues I've been having either. If I need to do anything on a computer I've chosen to use my work computer until I can get enough time to troubleshoot these display driver issues [apparent].

The "Display Mode" section under 'Settings'>'Display' is back now. Not sure when it returned. See below:

On another note:
Just today I notice that the HDMI audio has stopped working completely, when the previous day it worked 100% fine outputting a movie for family to my VIZIO with soundbar connected via eARC.

Audio to soundbar tested well with different inputs. It is only the computer running Zorin that magically cannot seem to output sound through HDMI any longer - overnight. Any thoughts?

Just an FYI: I've checked the software updater thinking the NVIDIA driver was the culprit; I even downgraded to 495 from 510. Also, I don't have a 'tested' proprietary driver as the help section of the site suggests. See mine below:

In the Display settings, are you able to set the External Monitor as the Primary display? This should cause applications to open there, instead of the notebook built-in.

It's quite easy and quick. Reboot, tap esc or tab or left shift key to bring up Advanced Options for Zorin - From this menu, you can arrow key to "Zorin on (Kernel Version)" choosing the version to boot up.

So, you suspect it is not the cable. I think would be on the right track with the Nvidia driver. But if you are running integrated graphics with Nvidia only on demand, it may be wise to ensure that your Intel Graphics drivers are up to the task.

Which is built into the kernel... So the portion above covering booting into a different kernel comes into play.

When you have a chance, please run

sudo lshw

In a terminal and use Pastebin.com to relay the output here. We can try to figure out which kernel may be the best one to try.

Thank you for your reply.
The below does still happen, just tested again this morning before post. Unsure how to post screenshot of the animation at work, I just hope you can visualize what I wrote below:

As for the not-so-important but OG issue of applications not opening up on primary monitor[external]. It does still happen, but most of the applications or programs I need to run tend to open up on the monitor I'm using as primary. So yeah, it isn't so crazy to have to pull a window over to my main display because it opened up on my alternate. It was really just a nuissance I noticed and wondered how to fix.

Magically, overnight, the HDMI audio out is working again. This is so confusing. I'd changed nothing since last posting - except I went to sleep and so did the PC. :confounded: EDIT1: Just remembered, also connected soundbar via bluetooth due to HDMI issues - that worked.
This being the case, I'm reluctant to upgrade back to the 510 driver but want to try. Hopefully this doesn't break it again.
EDIT2: Upgraded back to 510 and performed reboot - it was nice to hear the Zorin boot/login sound coming through my soundbar as I've been trying to make happen consistently. This leads to a logical conclusion of an issue with the soundbar or with the external display and their drivers somehow. Neither of which seem likely to me as they work now? All cables obviously work -though passing data inconsistently- since I haven't replaced any. Can't think of any other causes aside from the driver/software on the PC.

Also I will probably hold off on the kernel roll-back, but I am glad I now have a new troubleshooting step I can reference in the future.

I would like to say that I don't think I have that Intel "integrated graphics". Even when the machine formerly ran Windows, there was no option to switch between different cards being utilized - the only option has always been the NVIDIA RTX 3060 notebook card.

As requested:

Sorry for the detail :confused:

1 Like

I understand this... heavily. Something that interrupts your workflow is a bit more than just annoying, really.
As an example of my own... Whenever I use the Gnome Desktop, when I open a new instance, it opens it minimized instead of launching and opening the window. I must then find it on the panel and click it to open in.
In Zorin OS Lite, lauching a new instance opens that window right in front of me on the monitor. When editing multiple images - having this behavior is essential.
Minimizing it on open as Gnome does drives me up the wall. I can't stand it.
I have not looked into solving it because I do not use the Gnome Desktop... But if I was limited to just Gnome (Heaven forbid), I would need that solved before I could get anything done.

I wonder if your case is also affected by something about Gnome that annoys me: Only one panel. On Lite, I can create as many panels as I want and I can set them to be the ones the application appears to open on - or have them open on all of them, if I want. Or they can be set to open on the panel on the primary monitor. It's quite easy.
But Gnome only allows One Panel (Not including the topbar) and whatever app you launch, it is to that panel it will minimize.
Honestly, I have no idea how anyone can work under those conditions.

This is where I would focus attention, first.

This is the first thing I would try.

1 Like

100%-
Currently in process of trying to get UE5 Early Access up and running on it, and I've been largely successful, but have a few annoyances I need to get rid of first before I start, or my OCD (or whatever) will not allow me to focus on my projects.

Thank you, I will do the kernel rollback as soon as I get back on to fiddle around with the PC. There isn't much more that I can do with the drivers, I am back on the NVIDIA 510 proprietary instead of that earlier one to which I downgraded while troubleshooting this issue.

I've also noticed that when I turn off one of the monitors attached to the PC, and if I have Nautilus(file explorer) opened up on any of them; when the obligatory display flashing stops, the opened Nautilus window shows up on the built-in monitor and not the HDMI fed display I had it on previously - and it wasn't the monitor I just turned off either.

Regarding the Gnome Desktop, what is your preferred?
Also, was the pastebin log able to tell you anything?

Thanks so much for your time.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.