MX150 not being detected in Zorin 17 Core

I have an Acer laptop with integrated graphics and a Nvidia MX150 graphics card. No matter what I do, I cannot get it to recognize or switch to the card.

I installed Zorin 16 with the "modern graphics" version before upgrading with the upgrader, went to the additional drivers settings and tried 2 different ones, disabled secure boot, and the Nvidia Server X app is installed, but there are no card details only "Application Profiles" and "nvidia-settings-configuration".

Does anyone know how to fix this? Thanks!

Can you please launch a terminal and run:

sudo apt install nvidia-driver-535

Once complete without errors, reboot and test.
If there are any displayed errors, please relay them here.

No errors, and no changes. I am verifying by checking the "About" section in the settings. Graphics still says: Mesa Intel® UHD Graphics 620 (KBL GT2), which is my integrated graphics.

image

What is the output of

nvidia-smi

Have you used prime-select?

image
image

I attached the output. For prime-select, I can switch between them fine and it doesn't report any errors, but nothing changes when I switch to nvidia.

sudo prime-select nvidia
sudo rm /lib/modprobe.d/blacklist-nvidia.conf
sudo update-initramfs -u
sudo reboot

.... and test.

It said there was no such directory. Should I still try updating or something else?
image

Just continue. It was just incase that your card was blacklisted.

I ran the command and it completed, but provided no feedback. Still no change in my About section.

image

When I run the command ubuntu-drivers it shows the MX150, but nowhere else on my system. I tried installing the drivers through ubuntu earlier this week as well, but it did not work.

Thanks for helping by the way.

Try some of the drivers from here: Proprietary GPU Drivers : “Graphics Drivers” team
test the different drivers from there.

Also:

sudo apt install inxi
inxi -Ga

I tried two different packages (assuming I'm installing them correctly by adding the PPA and then using "sudo apt upgrade", but nothing has changed. This is the output for "inxi -Ga":
image

Why is it not installing or assigning drivers to the card?

I been searching the web and it seems you're not alone with the mx150 nvidia driver.

sudo apt install linux-headers-$(uname -r)
sudo apt install --reinstall nvidia-driver-545
sudo prime-select intel
sudo prime-select nvidia
sudo reboot
1 Like

That worked! No clue what was going on, but it's good for now. Thanks!
image

1 Like