My bluetooth headphones are not connecting

Every time i try to connect my headphones it says that it is connected but sound keeps coming out from my notebook (and my headset doesn't even say that it is connected). I was aready using Zorin for about 4 days and all these days the bluetooth worked perfectly! I aready tried to install the blueman and it actually worked, but everytime i close the app the headphones desconnect again! Is there anything i can do or some package i need to download?

I do not have bluetooth headphones or speaker, but installing blueman bluetooth manager has helped others in the past.

Yeah, it worked (kinda of) the sound start to coming out from my headphones but if i close the window of the blueman i recieve an notification saying "input/output error" then the sound keeps coming out from the notebook again.
Ps: With the blueman app open it works but if i stand the mouse in the headphone name it always apears "connecting" and the bar of "connecting" also never stops loading

You say bluetooth headphones were OK for firts 4 days of ZorinOS Core, then bluetooth problem. I wonder if it is kernel related. Have you tried choosing an older kernel on boot (grub menu) to see if there is an improvement?

1 Like

Not really, i'll try this, thanks! I'm new on ZorinOS and in Linux too lol
Is this going to delete everything i have in my notebook? Cause if that happens i'll put it all in a pendrive or something like that

If you boot to the grub menu and select Advanced options zorin, you should see a list of older linux kernel versions listed. Select an older generic kernel to try.

That should not delete any of your personal files or your setup, but it is always a good idea to back up your stuff before troubleshooting a problem.

1 Like

i just did it. As you said, probably a kernel issue (i saved all important things in a pendrive in case they were removed). It's working perfectly fine again, i still don't know what caused the problem, but it is working again and that's what matter lol

Thank you so much for your patience and help!! (and sorry if I said something wrong or didn't expressed my self right, English is not my first language)

No problems understanding your English. I assume your problem is a result of a linux kernel update, but I am glad it is back working.

Can you please tell us which kernel version caused you the problem and which kernel version you have rolled back to get your bt headphones back working.

You may need to select that old one again, if your issue is not corrected in a future kernel update.