My games are lagging when i am not plugged in but stop lagging when i am plugged in

So basically all my games lag when i am not plugged in and stop lagging once i plug in . this is very frustrating and i have tried restarting the pc , sudo upgrade,update. i still face this problem please provide me a solution.
Thank You

Have you checked powersave settings? It might be automatically kicking in when you go to battery as GNU/Linux eats more power than that other OS.

1 Like

I dint know where the powersave settings are since in the settings under power it does not show any kind of that setting

I'm not in Zorin at the moment, but from Fedora. It should look like this:

1 Like

sudo apt install gnome-shell-extension-cpupower

Go to Zorin Menu > System Tools > Tweaks (Gnome Tweaks), then go to the Extensions tab, and enable 'CPU Power Manager', and set up the CPU power profiles you want (I've got one that lets the CPU range across all its frequencies for normal usage, and one that locks it to its lowest frequency to save battery).

I'd recommend a profile that lets the CPU range over its frequency range for normal use, and another that pins the CPU to its maximum frequency for gaming... that'll affect your battery life, though.

In your menubar, you'll see a little chip icon. You can click that to change between profiles.


I installed it and set into high performance even then it shows 30-40fps on not plugged in and 60fps on pluged in

That's likely your GPU throttling back to save power. Depending upon which GPU you've got, you might have a configuration utility where you can change it to use more power when the computer's on battery... but do remember that the GPU absolutely sucks power... it'll run your battery down pretty quickly.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.