My Internal mic is not working in my newly installed zorin os

hey guy I'm Harisudhan and i installed zorin os and dual booted it with windows and everything is working fine, But i don't know why my microphone(even when connected to my earphone) is not working but it is working in windows tho please help me guys

If you search the forum there are multiple posts regarding this topic. You didn't include your version of Zorin, so any troubleshooting is a guess at best.
One fix that comes to mind and may be an issue is the ulsa mixer mic setting is muted. Another possible fix is to install and run puv control.
Welcome to the forum, please take the time to look around, you may find that someone has already dealt with your issue or a guide that will assist in future endeavors. Thanks for joining.

As 337harvey has mentioned, can you tell us what version and flavour of ZorinOS you are using e.g. Z15.3 Core, Lite etc or maybe Z16 Core Beta.
Also tell us about your machine and its sound card.

The first thing to look at is Zorin Settings>Sound and see if the mic appears there.

Second thing I would do is run Alsamixer from terminal and see if mic is muted (i.e. showing "M) and unmute it.
(I think that is what 337harvey meant by "ulsa mixer", but is a typo in his post)

See this: Internal microphone not working on new install - #3 by zabadabadoo

Also you will find several other threads re sound issues if you do a search on this forum.

Thank you for clarifying, it was my phone autocorrect that added the space to alsamixer...i wasn't sure if the terminal version or gui would be better to check the mic setting.

The terminal version should be included as standard with ZorinOS whereas the UI version would have to be installed. I have found the terminal version more than adequate and the UI version does no more.